We use cookies to ensure that we give you the best experience on our website. If you continue to use this site we will assume that you are happy with it.

Hi! Need help with Verge app and Blender!

Home Forums Graphics / Blender Hi! Need help with Verge app and Blender!

  • This topic has 40 replies, 2 voices, and was last updated 1 month ago by xeon.
Viewing 15 posts - 16 through 30 (of 39 total)
  • Author
    Posts
  • #42985
    ilzh
    Participant

    Here is Testproject3 log file text and picture

    v3d.js:1 Verge3D 3.5.0 for Blender (Trial, WebGL 2.0)
    v3d.js:1 v3d.WebGLRenderer: KHR_parallel_shader_compile extension not supported.
    get @ v3d.js:1
    Testproject32.bin:1 Failed to load resource: the server responded with a status of 404 (Not Found)

    can’t attach .log file here

    Attachments:
    You must be logged in to view attached files.
    #43016
    xeon
    Customer

    I would suggest downloading the latest Verge 3.7.1 and using that instead of 3.5 and also validating you are using Blender 2.9.3.

    Xeon
    Route 66 Digital
    Interactive Solutions

    #43017
    ilzh
    Participant

    xeon hello! i have really weak macbook pro 2010, i think that my mac can’t run newest blender, can you personally for me do this procedure and send me back folders with files, that i’ll can connect on my side?

    it’ll be a great happiness for me

    i’ll send to you my .blend file

    :heart:

    • This reply was modified 2 months ago by ilzh.
    • This reply was modified 2 months ago by ilzh.
    #43018
    ilzh
    Participant

    +

    • This reply was modified 2 months ago by ilzh.
    #43022
    xeon
    Customer

    Hi Ilzh,

    I am more than happy to take a look at the Blend file but given the age of your computer/software and compatibility between the latest versions and the versions you are running, I think there would still be issues if you try to take my files and insert them into your project.

    What version of Chrome or Safari are you using?

    Xeon
    Route 66 Digital
    Interactive Solutions

    #43026
    ilzh
    Participant

    i use safari 13.1.2 / high sierra

    i thought that you can make the project on your side using my .blend file and send the project to me

    let’s try!

    • This reply was modified 2 months ago by ilzh.
    #43033
    ilzh
    Participant

    xeon what do you think?

    • This reply was modified 2 months ago by ilzh.
    #43038
    xeon
    Customer

    Given your macbook what version of Chrome or Safari are you running? The limitations of that computer may be the core problem. But you can send the file… I wont have a way to review it for another day or so…I am generating large baked textures that take 4 days each…so have to wait that out before I can take a peak.

    Xeon
    Route 66 Digital
    Interactive Solutions

    #43039
    ilzh
    Participant

    ok, here is my .blend file

    https://disk.yandex.ru/d/ElEHo3EZtwgrNw

    good luck!)

    waiting for you feedback :)

    #43040
    ilzh
    Participant

    i’m using Safari 13.1.2, Chrome 87.0.4280.141

    here is my .blend file

    https://drive.google.com/file/d/1_ZlvKi60w-EKHn9M9RITkuCBrEAsBI4F/view?usp=sharing

    good luck

    wait for your feedback

    #43055
    xeon
    Customer

    Ok…google drive access requested.

    Xeon
    Route 66 Digital
    Interactive Solutions

    #43059
    ilzh
    Participant

    sorry

    access granted

    good luck

    #43060
    xeon
    Customer

    Have about 8 hours left on this bake then I can download and test…I will get back to you.

    Xeon
    Route 66 Digital
    Interactive Solutions

    #43061
    ilzh
    Participant

    ok

    #43069
    xeon
    Customer

    My render completed faster than I thought…so I was able to take a look at your file.

    When I import the file into Blender 2.9.3 I have four characters in posed positions. Once opened I just took a look in SneakPeak and everything rendered out as they appeared in Blender. Then I output the file as a GLTF and opened in puzzles….output was as expected.

    So there is nothing technically wrong with the blend file. However there are some issues / limitations with the armatures and Verge3d. The current armatures are throwing errors when imported into Verge3d as they are too complex or just not compatible (not sure which). On your old computer it probably just hangs up rather than giving you the error message in the console. You will want to pose, animate then bake all your animations and or your poses if possible. If not you will need to redo the armatures in 2.9.3 and minimize the number of them.

    You will also want to be sure that in your Blender Render Properties – Verge3d – Settings you have Bake Armature Actions. Please note, I have never found this to work well with complex armatures. I have found it just better to bake the entire thing into keyframes in blender and export that and then trigger the animation via puzzles.

    Note: As imported into Blender 2.9.2 The armatures are not set up as I would expect and are offset. This may be due to an incompatibility based on the version you are using. Removal of the armatures reset the models to their “T” positions and when put back into a verge3d project, the file did not throw any errors.

    I think the only way forward for you is to really get a new computer and then you will be able to diagnose these issues and fix them very quickly. If not you will be struggling with simple issues that as a developer we all encounter but they will seem very large obstacles given your configuration.

    Xeon
    Route 66 Digital
    Interactive Solutions

Viewing 15 posts - 16 through 30 (of 39 total)
  • You must be logged in to reply to this topic.