We use cookies to ensure that we give you the best experience on our website. If you continue to use this site we will assume that you are happy with it.

Verge3D local live server problem

Home Forums Programming Verge3D local live server problem

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #30906
    core3dcore3d
    Licensee

    Hi,
    When i try to import modules, verge3d local server gave me this error:

    “Failed to load module script: The server responded with a non-JavaScript MIME type of “text/plain”. Strict MIME type checking is enforced for module scripts per HTML spec.”
    I get same error when i upload to Verge3D CDN.

    But when i open my app inside Visual Studio Code and run it via live server it works fine. Also it works fine on my web server too.

    So, right now i have to finish everything with my puzzles then i import modules inside VCS. If i have to edit puzzles again i need to remove all module codes to open puzzles editor because of this error.

    How can i fix that?

    • This topic was modified 1 week, 5 days ago by core3dcore3d.
    #30977

    Hi,
    That’s strange because Verge3D code examples use modularized Verge3D and work great from both localhost and Verge3d Network. Maybe you are using some kind of firewall or proxy server?

    Co-founder and CTO at Soft8Soft
    FB | Twitter | VK

    #30987
    core3dcore3d
    Licensee

    You can check yourself, i tried with chrome, opera, firefox and also via vpn.
    no firewall and no proxy.

    https://cdn.soft8soft.com/AROAJSY2GOEHMOFUVPIOE:1e5e88da2e/applications/pointerlock/pointerlock.html

    #31004
    Yuri KovelenovYuri Kovelenov
    Developer

    Looks like you’re having an issue with MIME types. What operating system you got?

    3D Verger, the CEO
    LinkedIn | FB | Twitter | VK | 新浪微博

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.