We use cookies to ensure that we give you the best experience on our website. If you continue to use this site we will assume that you are happy with it.

mcolinp

Forum Replies Created

Viewing 15 posts - 1 through 15 (of 70 total)
  • Author
    Posts
  • in reply to: AR on human #64621
    mcolinp
    Customer

    I am interested in this use case as well, so I will be interested in what feedback you get.

    in reply to: No scene preview in Puzzles. #64617
    mcolinp
    Customer

    Thanks for pitching in to the conversation.


    @xeon
    I did try using other browsers such as Brave, Chrome, Edge and even Internet Explorer. All of them produce the same result. I did also sort out the red warning, it was related to a Firefox extension that is unrelated. I have disabled the extension, but no changes have occurred by doing that, other than that warning no longer being there.


    @Crunch
    I thought this too, but tit doesn’t explain why some older projects do load puzzles with previews, and I still get this result when making a default new app, without changing anything in the blend file.

    I did also mention that I am using 4.0.1 because I wasn’t in a position to renew when the time came up for my renewal.

    Looking for some official word from the Verge3D staff to give some clarity.

    • This reply was modified 1 year, 1 month ago by mcolinp. Reason: Forgot to include details about the warning, mentioned earlier by @xeon
    in reply to: No scene preview in Puzzles. #64566
    mcolinp
    Customer

    Can someone from Verge3D please provide some help with this?

    in reply to: No scene preview in Puzzles. #64456
    mcolinp
    Customer

    Sorry I forgot to check back on this. This screenshot shows the console errors. I am not sure what to make of it, if you have any suggestion, it would be much appreciated.

    • This reply was modified 1 year, 1 month ago by mcolinp.
    Attachments:
    You must be logged in to view attached files.
    in reply to: No scene preview in Puzzles. #64033
    mcolinp
    Customer

    Not sure if the zip file cam thru, so I am adding it again:

    mcolinp
    Customer

    Xeon That’s a very nice example. Is there some way you could share the puzzle configuration? Perhaps a screenshot of at least the puzzles used for the time rotation.

    This would be very helpful and much appreciated.

    mcolinp
    Customer

    Oh, and by the way, I believe that the issue with the hands behaving erratically before, was due to them each consisting of three different parts, two being parented to one of the three. I since combined them into one mesh, and that seems to have fixed that.

    mcolinp
    Customer

    I had to take some time away from this for a while, but I recently came back to it, trying to get the time working correctly.

    I tried using the example provided by alexopatin, though I seemed to have some issues with it. I recreated his puzzle setup as best I could, but I am unsure about the first puzzle inside each ‘do something’ container. It looks like it is just text, (in Russian, which I cannot read), but I see the puzzle comes from the “Advanced” section. It makes me wonder if the puzzle is related to javascript?

    So the attached picture is the setup I feel is best so far:

    It seems to work well most of the time, but it also seems to be incorrect at specific points in the 12 hour cycle. I have noticed that the hour hand jumps an hour ahead, when it passes the 12:00 mark. Also the time seemed correct when I was previewing it locally, then when I published it on the Verge3D network, it jumped an hour. I am still unsure if this is simply due to the cache in my browser, because later I looked at the Verge3D network link on my phone, and it seemed to be showing the correct time.

    My concern is that I am providing this example to show potential clients, etc. I need confidence that no matter when they view it, it will be accurate to the actual time. And if I leave it running, it should not over time, become inaccurate.

    Here is a link to the current published setup:
    Brakeman Watch Configurator

    I can provide the application data, but would prefer to send it though a private message. Thank you again.

    Attachments:
    You must be logged in to view attached files.
    in reply to: BUG REPORT: collections within collections dissapear #42184
    mcolinp
    Customer

    It provides a much better way of managing large assemblies. So if I make something like a bicycle, I would have a frame with components. So lets say the brakes, have many individual components such as cables, caliper, disc, lever etc. I want to be able to manage/link or import collections at different levels. I might also have several options within the upper collection containers. A good example of this was a watch I designed, which had multiple options for Hands, Markers/Numbers, and Bezels. So I have a Top Container that is Called “Bezel”, and then inside I have several distinctly unique bezels, but only one is present in any configuration. So I turn off (untick) the collections not in use for the given configuration. I also can tick on a different set of components using multiple “scenes” in blender.

    I have been a little unsure how to best structure files for use in Verge3D. Up till recently, I painstakingly structured files with collections, and made liked proxies of each individual mesh object. It made it so all the materials can be applied in the main file to the proxy objects.

    In my most recent file, I decided to use linked collections instead of linking individual proxy objects. The trade off, is that I have to apply materials in the linked files, as you cannot apply materials to collections. So I link all the files to the same material blend file, to ensure materials are not accidentally duplicated.

    With blender, there is so much flexibility, that it can be difficult to grasp the best file structure workflow pipeline; especially with specific parameters needed for Verge3D output.

    mcolinp
    Customer

    I found this bug report on developer.blender.org:

    T88678

    It seems to be related, but in releases before 2.93, I only noticed this behavior once I started working and test a scene/file in Verge3D.

    mcolinp
    Customer

    I should also say, that I do not experience this same behavior in blender files which are not being used as a Verge3D project or application.

    mcolinp
    Customer

    So I have tried many times to get Morph Factor to work; and have never succeeded. I am desperate, and need help; as I will need to wrap this up for a presentation in a week or two. The app will need to accomplish 3 things:

    1) all the pieces of the wall will be part of an exploded view animation; which only happens when the “Arrow Out” object is clicked.

    2) No matter what state that animation is in (exploded or not), several the pieces of the wall need to move based on inputs from clicking on the ‘ARROW UP’ & ‘ARROW DOWN’ which are visible to the side of the wall. *This works.

    3) The Panels that appear to be the exterior covers of the wall, (‘[FRT] APPLIQUE’ and ‘[BAK] APPLIQUE’); must change shape using a Morph Factor. They need to adjust to the changing height of the other parts, in the same 6 inch increments. Overall the arrows should never allow the wall to go beyond 11 feet tall, or below 8 feet tall. Also, the Morph Factor parts, also need to not skew or distort the UV texture maps when using the Morph Factor.

    I am not entirely sure if all these things are possible. I would appreciate if someone could clarify if I am attempting anything that ultimately is not possible at this time. And if so, exactly which part.

    I am providing a link to a simplified version of my file, so that you can hopefully see what may be causing the Morph Factor to not work properly.

    Please see the zipped application file here:
    https://app.box.com/s/970afen1psmkocgo7gx662s7axoicm93

    Thank you in advance.

    mcolinp
    Customer

    Another thing I am struggling tom grasp, is Morph Targets. How are these defined? I never seem to have any Morph Targets . . .

    mcolinp
    Customer

    Another:

    Attachments:
    You must be logged in to view attached files.
    mcolinp
    Customer

    Here is an updated screenshot of what I have tried based on what you have suggested.

    Attachments:
    You must be logged in to view attached files.
Viewing 15 posts - 1 through 15 (of 70 total)