We use cookies to ensure that we give you the best experience on our website. If you continue to use this site we will assume that you are happy with it.

White outline around textures

Home Forums Graphics / Blender White outline around textures

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #56885
    Ayakos
    Participant

    Hello community,
    I’ve searched the forums for something similar but found nothing. Basically I want the final render in verge to look like the “premultiply setting” for alpha setting inside blender, but it doesn’t seems to pick up on this setting and it looks like simple “straight” option.
    How can I make verge renderer accept this change?

    I have a couple of pictures to illustrate what I mean. Straight setting will have a white outline around transparent textures, while premultiply will get rid of it and make it look far superior.

    Attachments:
    You must be logged in to view attached files.
    #56890
    xeon
    Customer

    Could you post your material nodes and your object blend settings along with zdepth. Blender uses Premaultiply by default and V3D seems to handle that pretty well. I think you may have something else going on but would need more info.

    Xeon
    Route 66 Digital
    Interactive Solutions - https://www.r66d.com

    #56932
    Ayakos
    Participant

    Yeah of course, here it is.

    Attachments:
    You must be logged in to view attached files.
    #56934
    xeon
    Customer

    What version of Blender are you using? I am using 3.3 and have been able to replicate the problem. I am not sure at this time if its a Blender bug or a V3D bug.

    Blender by default Premultiplied was the method Blender had been using but now the default seems to be standard which does create the white lines. Premultiplied gets rid of them in Blender but I am not certain V3D is picking up on the settings change. I will reach out through the Enterprise channel and see if they can provide any insight.

    Xeon
    Route 66 Digital
    Interactive Solutions - https://www.r66d.com

    #56935
    Ayakos
    Participant

    Thank you. I’m using version 3.1 of Blender.

    #56936
    xeon
    Customer

    and what version of v3d?

    Xeon
    Route 66 Digital
    Interactive Solutions - https://www.r66d.com

    #56937
    Ayakos
    Participant

    Latest I think? 4.1.1

    #56938
    xeon
    Customer

    Feedback from Soft8Soft – “Alpha Premultiplied is not supported in Verge3d yet. I (Alexandar) am going to assign this task a higher priority in order to deliver this feature in the upcoming stable release of 4.2.0.”

    Seems we will be waiting a bit to fix this…. Since you are using Blender 3.1 you may want to drop back to V3D 3.9.1 and give that a try.

    Xeon
    Route 66 Digital
    Interactive Solutions - https://www.r66d.com

    #56939
    Ayakos
    Participant

    Ok Thanks a lot for the support!

    #58637
    Ayakos
    Participant

    Hello there, sorry for bumping this necro thread, but it’s relevant to 4.2’s release, as premultiplied was supposed to be supported now, but it still doesn’t seem to work, and textures look the same as “simple” setting.

    I can provide full blender file in case my node setup is bad.

    Link: https://drive.google.com/file/d/1O9sQZAK8UuBTwczcV9nGv7aTI6waKvLL/view?usp=share_link

    #58683

    Hi, perhaps this something else there. Can you please make a primitive Blender scene with just a single plane with this texture/material assigned, so we could investigate further?

    Verge3D’s Tech Chief
    FB | Twitter | VK

    #58699
    kdv
    Participant

    In the release example the texture with the premulriplied alpha channel differes from the other three ones. The other three textures do not look like the second one even if their alpha is set to Premultiplied too. They are initially different in RGB channels.

    One more thing: in his textures the image in the alpha channel is thicker. Cells in RGB are white inside (but should be black). That’s why there are white outlines inside cells.

    It looks as expected if the RGB image is black inside cells. Just make a proper texture.

    https://v3d.net/d20

    Straight Alpha

    Pre-multiplied Alpha. It works. Looks more blue.

    #58718
    Ayakos
    Participant

    Thanks for the insight, but can you explain precisely what it is you did with the texture files for it to work?

    #58719
    kdv
    Participant

    That’s your texture in RGB, without alpha.

    That’s how it should look to work properly.

    #58722
    Ayakos
    Participant

    I see, thanks a lot!

Viewing 15 posts - 1 through 15 (of 15 total)
  • You must be logged in to reply to this topic.