We use cookies to ensure that we give you the best experience on our website. If you continue to use this site we will assume that you are happy with it.

V4 pre4 IOS weird clipping

Home Forums Bug Reports and Feature Requests V4 pre4 IOS weird clipping

Tagged: 

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #51762
    plan8
    Participant

    Hi,

    I am using V4 pre4 and the project I am working on displays just fine on windows chrome and android mobile, but no matter what browser I use in IOS, I get weird zdepth issues, looks like half the screen goes either in front or behind depending on camera angle as well as sometimes completely going all white. Same in all three browser I tried in Ios Chrome – safari and xrviewer

    Attachments:
    You must be logged in to view attached files.
    #51789

    hi,

    you might try to bring the Far and Near planes of the camera closer to each other.

    Chief 3D Verger | LinkedIn | Twitter

    #51929
    plan8
    Participant

    Hi there Yuri,

    Sorry, I forgot to check the email notification box for this topic.

    I don’t think it’s the near Far clipping planes, I’m pretty confident its a bug that Apple have apparently fixed for the next iOS release where safari has WEBGL via Metal enabled by default which screws everything up.

    If you switch this off in developer settings, it more or less runs ok, but with no hdr antialiasing capability and is very dark.

    #51938

    There were fixes related to the latest iOS update in Verge3D 3.9.1 and 4.0 preview. You might try switching if you are using older versions.

    EDIT If you are already using 4.0, make sure the app was actually updated by checking browser console output.

    Chief 3D Verger | LinkedIn | Twitter

    #51941
    plan8
    Participant

    Hi,

    I am using V4 pre 4 – how would I update the app?

    #51942
    plan8
    Participant

    It appears it is V 4 but pre 1 – how do I update this to pre 4?

    Verge3D 4.0.0 pre1 for Blender (Trial, WebGL 2.0)

    EDIT – dont worry, I found the refresh button and is now V4 pre4 – thanks!

    • This reply was modified 6 months, 3 weeks ago by plan8.
Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.