We use cookies to ensure that we give you the best experience on our website. If you continue to use this site we will assume that you are happy with it.

Localhost refused to Connect with Chrome 83.0.4103.61 on macOS High Sierra

Home Forums Graphics / Blender Localhost refused to Connect with Chrome 83.0.4103.61 on macOS High Sierra

Viewing 15 posts - 1 through 15 (of 34 total)
  • Author
    Posts
  • #28297

    When I run Sneak Peek or App Manager from Blender 2.82a, I get an error message in Chrome stating “localhost refused to connect”.

    What methods are available for resolving this issue? Thank you.

    #28349

    Hi,

    You should try to run Blender from the terminal. If you have Blender installed in Applications, then you can open the terminal and enter something like this:

    If all goes well the terminal’s output should say Starting App Manager server (port 8668, package BLENDER) among other blender-related log messages. That means that you should be able to access http://localhost:8668/.

    But, if you really have problems with verge3d app manager, then there can be error mesages instead, i.e. server crash, addon errors, etc…

    Co-founder and lead developer at Soft8Soft.

    #28972

    Excellent! Thanks Ivan. I will give that a shot and let you know what happens. Much appreciated.

    #28995

    This command did return the output: Starting App Manager server (port 8668, package BLENDER). But the next output was: Address already in use, exiting.
    This explains why it cannot resolve the host, because it is being blocked by another process or application. Is there a method for determining what may be using localhost:8668?

    #29112

    Is there a method for determining what may be using localhost:8668?

    Yes, try to execute the following command in the terminal:

    its output should indicate if this port is actually used or not and what process may be using it.

    Co-founder and lead developer at Soft8Soft.

    #29383

    I gave that a shot, but it returned no output. I tried lsof -i to look at a list of all ports and the PID column skips from 8215 to 12995. Port 8668 is not listed.

    #29413

    I gave that a shot, but it returned no output.

    This probably means that the error is caused by something else and not by an already used port.

    We can try to investigate that. In the verge3d/manager/ folder there should be a file called server.py, which is responsible for starting the verge3d server. Here’s an archive with a slightly modified version of that file: server.zip. If you replace the original file with it (make a backup just in case) then you’ll get more detailed info about the error in the terminal’s output.

    Attachments:
    You must be logged in to view attached files.

    Co-founder and lead developer at Soft8Soft.

    #29575

    Thanks, Ivan. I appreciate your help with this. Attached is a screenshot showing the output from terminal and python launcher if that helps. I’m just not getting a response out of that command.

    Attachments:
    You must be logged in to view attached files.
    #29583

    Hmm, it seems that you run server.py manually, but it’s not actually needed because Blender should execute that script properly, i.e. by using the appropriate python version and some specific command line arguments. I guess that’s the reason you got the Syntax Error.

    So, you just need to launch Blender the same way via the terminal as I suggested in the previous post.

    Co-founder and lead developer at Soft8Soft.

    #29590

    I did that as well. Sorry, I should have mentioned that. I’m getting the same localhost refused message from the browser. I’ve checked my firewall and proxy settings, and there’s nothing going on there that would block localhost.

    I have no issue with this working on my PC on the same network, by the way; so this is only an issue with my desktop Mac running High Sierra. My MacBook Pro running Catalina works perfectly.

    Though it would be cool to resolve this issue, it isn’t keeping me from creating projects with Verge3D, so there’s no urgency here.

    Attachments:
    You must be logged in to view attached files.
    #29610

    Oh, sorry, I should’ve been more clear. After you replace the file server.py within the verge3d/manager directory you should just run Blender from the terminal and look at the output there previously was just “Address already in use, exiting”. But now with the new version of server.py there should be a bit more information about what actually happened when Blender tried to start the server.

    Co-founder and lead developer at Soft8Soft.

    #30805

    Hey Ivan. Sorry it’s taken me a while to get back to this. I’ve attached a screenshot of what came up in terminal. Let me know if there’s anything else I should try. Many thanks!

    #30870

    Hi,

    This looks like a different error to me. We’ve recently released Verge3D version 3.3.0, which I think shouldn’t even have this error with the missing “merger” module. Can you try to update your version and check if it’s still reproduced? Also, maybe updating will resolve the original issue with localhost being not accessible.

    Co-founder and lead developer at Soft8Soft.

    #30879

    Hi Ivan,

    I’ve wiped all previous versions off of this machine, and I’ve downloaded and installed Blender 2.83.3 as well as Verge 3.3.0, and now I’ve come across a new error message in Blender when I checked the Add-On box in Blender Preferences. I’ve attached a screenshot of it here for reference.

    Again, there’s no rush on my side. I’ve got Blender and Verge running on my PC and my MacBook, but I thought you’d want to troubleshoot this type of stuff.

    Thanks for your help and continued patience.

    Attachments:
    You must be logged in to view attached files.
    #30903

    Hi,
    Please check your Scripts path in the Blender prefrences:

    Is it pointing to the new Verge3D 3.3 installation?

    Co-founder and CTO at Soft8Soft
    FB | Twitter | VK

Viewing 15 posts - 1 through 15 (of 34 total)
  • You must be logged in to reply to this topic.