We use cookies to ensure that we give you the best experience on our website. If you continue to use this site we will assume that you are happy with it.

Global lighting (3DS Max) doesn’t work at all in 4.0 pre1 build

Home Forums Bug Reports and Feature Requests Global lighting (3DS Max) doesn’t work at all in 4.0 pre1 build

Viewing 15 posts - 1 through 15 (of 16 total)
  • Author
    Posts
  • #50376
    vern
    Customer

    Global lighting does not work at all in the 4.0 pre1 build. Any changes doesn’t affect the scene in Verge3D. Also in previous scenes from 3.9 that are opened in 4.0 pre1 show lighting that is super super bright (pretty sure it has to do with the global lighting).

    Definitely a bug since it works perfectly in 3.9 right? I also attached some pictures.

    • This topic was modified 6 months, 3 weeks ago by vern.
    Attachments:
    You must be logged in to view attached files.
    #50389

    Hi,

    Thanks for the heads up. This will likely be fixed in v.4.0 pre2 expected on Monday.

    Chief 3D Verger | LinkedIn | Twitter

    #50594
    vern
    Customer

    I just downloaded 4.0 pre3 build and Global lighting still does not work at all in 3DS Max. :(
    Any scene sent to Verge3D doesn’t change at all when a change is made in the Global Lighting menu in 3DS Max. Just like in the pic I sent earlier, everything is super super bright.

    Was this issue fixed and maybe I’m missing something?

    I really need this so my projects can be launched since I can’t go back to 3.9, because I really need the line rendering and 360 vertical camera from the 4.0 pre builds.

    • This reply was modified 6 months, 2 weeks ago by vern.
    • This reply was modified 6 months, 2 weeks ago by vern.
    #50599

    Hi, is it possible that the app itself was not updated (please check Verge3D version in browser console)? Perhaps you should also reexport your max scene and resave Puzzles.

    Verge3D’s Tech Chief
    FB | Twitter | VK

    #50644
    vern
    Customer

    Hello,
    Yes, I did make sure to do all 3 of those checks previously (reexport, saved Puzzles, and checked my Verge3D version).

    Yes my version shows Verge3D 4.0.0pre3

    I didn’t try pre2 I went straight from pre1 to pre3.
    Should I try pre2 maybe?

    I tried to reply yesterday but it seems I couldn’t open the forums or any Verge3D web page.

    #50870
    vern
    Customer

    Hello,
    Is there any update on when this issue will get fixed?

    #50874

    hi,

    sorry for not replying earlier. Can you please share your project with us?

    Chief 3D Verger | LinkedIn | Twitter

    #50909
    vern
    Customer

    Sure, I made a sample project to show you since it happens on any project from version 4.0 pre1 and newer.

    Here is the link:
    https://v3d.net/5h9

    The scene should show light just from the environment but it doesn’t. I have to add physical or actual lights instead of using global lighting. The scene in Verge3d doesn’t change when Tint or Tint Level are adjusted in the Environment settings in 3DS Max. I’m just using a solid color background (no map).

    I have lights (Photometric) in the scene but turned them off for the test.

    Please see attached.

    Attachments:
    You must be logged in to view attached files.
    #50963
    vern
    Customer

    Hi Yuri,
    Did you have a chance to look into this to see what the issue might be?

    I’m really hoping to use only the environment lighting for performance reasons.

    #50979

    Hi,
    I’ve checked the source files and they appear to include default cube. Can you please send us complete project with proper max file?

    Verge3D’s Tech Chief
    FB | Twitter | VK

    #50982
    vern
    Customer

    Sorry about that, I’m not sure why the source files weren’t correct after zipping it. I attached the correct zipped project folder.

    Attachments:
    You must be logged in to view attached files.
    #51045
    vern
    Customer

    Hello guys,
    Have you had a chance to check out this issue or do you have a fix for it?

    #51133
    vern
    Customer

    Any update on this?

    #51135

    Hi,

    Checked your file. Looks like you disabled specular lighting by using Light Probe (Fast) as IBL Environment Mode. This is an over-optimization feature for really slow devices. Please use PMREM for more correct lighting (see screen attached).

    Regarding Tint value, we do not support this feature since in does not supported in Physical renders (like ART or Arnold). So it should be always set to 1.

    Attachments:
    You must be logged in to view attached files.

    Verge3D’s Tech Chief
    FB | Twitter | VK

    #51140
    vern
    Customer

    So I tested it using all 3 IBL Environment settings and it doesn’t change my lighting at all.
    All I want is to use a color background and to use environment global lighting, just like I was in 3.9.

    If I do not add actual lights into my scene and only use environment lighting, the entire scene has an insanely bright (high intensity) light that I can’t adjust. You can see what I mean in the first attached image below.

    If I add actual lights to my scene (instead of using environment lighting) than I can get the lighting better as you can see in the second attached image.
    But I need to use environment lighting for performance reasons and I can’t use it at all because of the aforementioned issue.

    Can you please tell me how to get the normal environment global lighting back, just like it was in 3.9 please?

    Attachments:
    You must be logged in to view attached files.
Viewing 15 posts - 1 through 15 (of 16 total)
  • You must be logged in to reply to this topic.