Home Forums Graphics / Blender Some vertice won't take weight

This topic contains 28 replies, has 3 voices, and was last updated by Mikhail Luzyanin Mikhail Luzyanin 1 week, 1 day ago.

Viewing 14 posts - 16 through 29 (of 29 total)
  • Author
    Posts
  • #2593
    Philip Fong
    Philip Fong
    Licensee

    Trex-2018

    Verge 3D

    By the way, your loader image not clean. :)

    • This reply was modified 1 year, 3 months ago by Philip Fong Philip Fong.
    #2595

    By the way, your loader image not clean

    What browser and device do you use?

    Co-founder and lead graphics specialist at Soft8Soft.

    #2597
    Philip Fong
    Philip Fong
    Licensee

    Firefox, Xiaomi phone.

    #2605

    Nothing change to the dino, just the weight paint clean up and environment texture.

    When shadow is enabled, the blurry effect look less obvious.

    Ok, we try to reproduce the issue on different PC. Can you also test your model on different PC and look is the problem appears everywhere or not and write wich hardware do you used for tests? Because we still can’t find the difference on our PCs.

    Firefox, Xiaomi phone.

    Thank you will look at it closely.

    Co-founder and lead graphics specialist at Soft8Soft.

    #2676
    Philip Fong
    Philip Fong
    Licensee

    Think the blurry effect is mip map in Verge3D, zoom in and out will see the difference, I hope by scaling the whole scene can control the distance.

    #2691

    Think the blurry effect is mip map in Verge3D, zoom in and out will see the difference, I hope by scaling the whole scene can control the distance.

    I found why you see the difference. You used the diffuse texture also as bum map, as I can see in your screenshots and blender file where you set up a bump as 0.187. It give add some details to the texture so it looks like it less stretchy, but in the engine bump is not supported and it omited. Try to bake normal. Because we testet your model on multiple PC and can’t find the difference. We see the difference only if we switch on the bump on the model and try to export.

    Co-founder and lead graphics specialist at Soft8Soft.

    #2698
    Philip Fong
    Philip Fong
    Licensee

    The latest scene is a baked texture, only my first test has bump map.Trex-web

    Blender-Trex-zip

    • This reply was modified 1 year, 3 months ago by Philip Fong Philip Fong.
    Attachments:
    You must be logged in to view attached files.
    #2703

    The latest scene is a baked texture, only my first test has bump map.Trex-web

    Ok, thank you for the new example, as I said before the texture in the old and new examples little different and now we can see the difference in blender and the engine. It’s because of anisotropic filtering, we’ll added it to our TODO list and it will be available to enable it in one of the next releases.

    Co-founder and lead graphics specialist at Soft8Soft.

    #15502
    Avatar
    tomcd
    Newbie

    Dear Developers,

    I made some animation with 4 bones (m, m.001, m.002, m.003) controlling the mouth movement with weight paint. I clean up all other bones weight paint that may affect the mouth. The result looks fine inside Blender & Cycle, but when view in “sneak peek” at the end the mouth movement gone wrong.
    Could you please help? Thank you!

    I attached the Blender file

    Attachments:
    You must be logged in to view attached files.
    #15505

    I made some animation with 4 bones (m, m.001, m.002, m.003) controlling the mouth movement with weight paint. I clean up all other bones weight paint that may affect the mouth. The result looks fine inside Blender & Cycle, but when view in “sneak peek” at the end the mouth movement gone wrong.
    Could you please help? Thank you!

    Hi, you need to clean all weight with 0. I done it for you on the character’s head and it’s started to work propertly. (see atachhed file)

    Attachments:
    You must be logged in to view attached files.

    Co-founder and lead graphics specialist at Soft8Soft.

    #15508
    Avatar
    tomcd
    Newbie

    Thanks! But I cannot open the file. I am using Blender 2.79b (company pc cannot run 2.8). Do I need to Select the head> edit mode> select all vertex> object data tab>Vertex Groups> set weight bar from 1.000 to 0 ?

    #15509

    Thanks! But I cannot open the file. I am using Blender 2.79b (company pc cannot run 2.8). Do I need to Select the head> edit mode> select all vertex> object data tab>Vertex Groups> set weight bar from 1.000 to 0 ?

    You just need to go to vertex weight paint mode and on the left pannel select Clean then All Vertex Groups and set limit to 0.001

    Co-founder and lead graphics specialist at Soft8Soft.

    #15510
    Avatar
    tomcd
    Newbie

    It’s working fine now! Thank you very much !

    #15511

    :good:

    Co-founder and lead graphics specialist at Soft8Soft.

Viewing 14 posts - 16 through 29 (of 29 total)

You must be logged in to reply to this topic.