We use cookies to ensure that we give you the best experience on our website. If you continue to use this site we will assume that you are happy with it.

Flying in object choppy

Home Forums Puzzles Flying in object choppy

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #30802
    Avatarweb
    Licensee

    I’m trying to do a intro animation. The object is outside of the camera sight, and I want the object to move into it.

    Problem is that when the object becomes visible the animation is choppy the first 1-5 frames. I think that verge try’s to dynamically load shaders and stuff.

    How can I prevent that and get a silky smooth animation?

    #30822

    Can you share the project? Or reproduce the problem on a simple file?

    Co-founder and lead graphics specialist at Soft8Soft.

    #30845
    Avatarweb
    Licensee

    Sadly I cant share the files in public. I tried to reproduce a simple file but it seems to be a sum of things and not single parts. When I apply one material to all the objects the animation is running smoothly from start to end.

    The geometry is around 360k polys, consisting of 67 single objects grouped together (using 3dsMax btw). 192 render calls, 64 geometry buffers.

    At the moment I discarded that approach, and just let the whole v3d-container fade in.

    #30859

    Sadly I cant share the files in public. I tried to reproduce a simple file but it seems to be a sum of things and not single parts. When I apply one material to all the objects the animation is running smoothly from start to end.

    You can try to disable each thing one by one, for example disable material, shapekeys (if exist), armature etc. to understand what exactly produce such behavior.

    Co-founder and lead graphics specialist at Soft8Soft.

    #30861
    Avatarweb
    Licensee

    Thx for the tip. I already tried that approach but couldnt find “the material”. Its really a sum of all.

    When I find a way to reproduce it will write back here.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.