We use cookies to ensure that we give you the best experience on our website. If you continue to use this site we will assume that you are happy with it.

Home Forums Bug Reports and Feature Requests Woocommerce communication not working

Viewing 4 posts - 16 through 19 (of 19 total)
  • Author
  • #37335

    Hi there,
    Is there a universal solution for this issue?
    I seem to have a similar problem with the 3D model not reflecting the woocommerce attribute change.
    What I want to achieve is when the user changes the “height” attribute, the middle section of the 3d model prolongs to 50mm. The basic height is 45mm.
    My setup:
    – blender 2.91.0
    – verge3D 3.5.0
    – wordpress 5.6 with hestia theme 3.0.8
    – woocommerce 4.9
    When I test the morph factor in the puzzles editor with the command “when hovered”, the model changes, but it doesn’t seem to work with woocommerce. When I change the attribute, the model remains the same. And the console displays the error as seen in the printscreen.
    One other anomaly is when I change the product attribute from the default 45mm to the first option “choose an option”, the cart button gets disabled and isn’t available even if I reselect “45mm” or “50mm”.
    Solutions I’ve tried:
    – deactivating and reactivating the verge3D plugin,
    – removing the model application, creating a new model application and reassigning it to the product,
    – changing the puzzle if/else statements to include all of the four combinations of height (if 45 then 0, else 45 = 1; if 50 then 1, else 50 = 0).
    I’m running a local wordpress installation via xampp, so unfortunately I can’t give you admin access.
    Please let me know if you need any info to resolve the issue.
    Thanks in advance.

    You must be logged in to view attached files.


    You can try enabling the option ‘Enable AJAX add to cart buttons on archives’ in WooCommerce settings and see if it helps:

    3D Verger, the CEO
    LinkedIn | FB | Twitter | VK | 新浪微博


    Hi, Yuri,

    Thanks so much for the prompt reply – enabling AJAX did help! :good:



    This issue was fixed in the Verge3D 3.6 release. Please check it out.

    Verge3D’s Tech Chief
    FB | Twitter | VK

Viewing 4 posts - 16 through 19 (of 19 total)
  • You must be logged in to reply to this topic.