We use cookies to ensure that we give you the best experience on our website. If you continue to use this site we will assume that you are happy with it.

Switching to Blender 2.8

Home Forums Graphics / Blender Switching to Blender 2.8

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #12904
    Crunch
    Customer

    Sorry for a total newb question but how do I get the app manager to load the selected project in blender 2.8?

    I am referring to when I click on the Blender icon in the app manager.

    I have Blender 2.7 installed and Verge3d (old version) configured. Worked great.

    Now I downloaded blender 2.8 beta and run it from exe in the folder. Next I downloaded verge3d 2.11 and followed the directions for configuring it in Blender 2.8. When I click on app manager within blender 2.8, the app manager (v 2.11) launches as expected.

    The issue is, when I click on the blender icon in app manager it by default opens the blend file in my old 2.7 version of Blender.

    I changed the file association in windows 10 for the .blend to open with the new2.8 exe but the app manager still defaults to blender 2.7. Help would be appreciated. Thanks

    • This topic was modified 2 years, 10 months ago by wpadm. Reason: moved to Blender forum
    #12907
    Ozbend
    Customer

    I think, you can’t do this until it is a beta version.

    • This reply was modified 2 years, 10 months ago by Ozbend.
    #12926

    Hi,

    You need to make Blender 2.8 the default program for opening .blend files. You can change file associations on Windows 10 as described here.

    Chief 3D Verger | LinkedIn | Twitter

    #12974
    Crunch
    Customer

    Thanks Yuri but it appears Ozbend might be right that we (windows 10 users) might have to wait for version of 2.8 with an installer.

    It appears Windows 10 (ver 1803) removed the option of manually locating the application to set the default association with the file type. It only gives the option of searching the “MS app store”. It’s a known issue according to this article:

    https://www.ghacks.net/2016/02/16/how-to-make-any-program-the-default-on-windows-10/

    The article suggests a 3rd party utility might fix it but I prefer not to install 3rd party utilities.

    Something else I just noticed, I created a blend file with 2.8 and saved it. I close Blender 2.8 then find the file in windows explorer. I right click the file and select “open with”. With this method, it does allow me the option to manually ‘search my pc for app’, where I select the location of my Blender 2.8 exe… but it still opens with Blender 2.7!?

    If I start Blender 2.8 and use Open feature the file opens as expected. Is this how everyone else (windows 10 build 1803) opens .blend files in 2.8?

    #12977
    elk
    Customer

    I think this is a regular problem with Blender, also with 2.79 and earlier I have had problems. I usualy have multiple versions of Blender on my system at a time for different tasks or testing (using the zip download), and I usualy open files from within Blender. Every so often i try to point the “default app”-thing to a new version, but I haven´t got it working in a long time (I´m on Win7). I guess this might be fixed once 2.8 gets an installer, if you want to go with installer. You might want to uninstall the “old” Blender that now opens by default, and try to force Windows to realise that there is no “link” there anymore, but i doubt this will work either. If it is really important to you there should be some suggestions that are more invasive to Windows to try and fix it if you do some searching, I never had much luck tho. And just remember to be careful what you change if you need to go into the deeper systems of the OS to try anything.

    #12980
    Crunch
    Customer

    Elk I was contemplating uninstalling 2.79 and hoping that would force windows to find 2.8 but also figured/worried it won’t fix anything and probably cause more problems.

    Normally this wouldn’t be that big of deal for me (I am such a newb at blender I don’t produce anything yet worth saving) but when I run the Verge3d app, selecting the blend file triggers 2.79 to open. I think as a newb staying within the framework/workflow of the app is good practice so I don’t screw anything up.

    I agree though this is a Microsoft issue. It almost seems like removing the option to search your computer for an app in the new “default settings menu” was some ‘strategic’ move by MS to drive more traffic to their App Store. How stupid.

    I chatted with a MS tech this morning and showed the tech links to the webpages discussing the problem and commented how ridiculous it was MS hasn’t addressed it. After sending me a few work-arounds the tech had googled (one being from 2016!) the last one was this.

    https://superuser.com/questions/1080453/adding-or-registering-a-file-type-so-it-can-be-associated-with-an-application

    The answer with 8 upvotes that begins “If all else fails, you can try to resort to commandline manipulations”

    I am not sure about doing what is suggest there either, as sometimes messing with that stuff can cause more problems later.

    I posted this over in BlenderArtists.org to see if anyone else had insight on this issue

    https://blenderartists.org/t/making-blender-2-8-default-for-blend-files-windows-10/1151943

    #12990
    Crunch
    Customer

    So i ended up uninstalling 2.79

    I right clicked on a blend file in windows explorer then selected “open with” and chose my Blender 2.8 exe file, everything stuck this time and is now working perfectly!

    Now i can get back to Verging :) thanks

    #13013

    @Crunch Glad you managed to fix that! :yahoo:
    @elk thanks for helping out! :good:

    Chief 3D Verger | LinkedIn | Twitter

    #13027
    elk
    Customer

    No problem. :good:

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.