Strange Camera behavior

Home Forums Bug Reports and Feature Requests Strange Camera behavior

This topic contains 4 replies, has 2 voices, and was last updated by Yuri Kovelenov Yuri Kovelenov 3 weeks, 6 days ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #20230

    Hi all,
    I’ve been developing our first Verge3D project for a couple of weeks now.
    I still can’t understand this weird camera behavior, Tween Camera to object works fine but the rotation is not translated and corrects itself in the last frame.

    Here is the video: https://www.dropbox.com/s/8199bsi7dlc3bou/2019-10-14%2011-06-07.mp4?dl=0

    One more question: is there a way to override default controls and assign mine? We are using touch displays and it needs 2 fingers to move the camera and single touch to rotate around the target, I need to swap that behavior.

    :bye:

    #20277
    Yuri Kovelenov
    Yuri Kovelenov
    Developer

    Hi,

    try positioning the camera not exactly at 90 degrees to the surface (make it say 89.9). It just cannot determine the up vector properly.

    3D Verger, the CEO
    LinkedIn | FB | Twitter | VK | 新浪微博

    #20278

    Thank Yuri, this was my first thought. I have adjusted the camera as you said but it is still the same.

    #20279

    I have shifted targets and camera dummies by a few degrees and this problem is somehow gone but I cannot keep the camera position to keep north, its all kinda random.

    #20313
    Yuri Kovelenov
    Yuri Kovelenov
    Developer

    can you prepare a simplistic example for us to look into?

    3D Verger, the CEO
    LinkedIn | FB | Twitter | VK | 新浪微博

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.