Shadows in 2.8beta

Home Forums Graphics / Blender Shadows in 2.8beta

This topic contains 9 replies, has 2 voices, and was last updated by Yuri Kovelenov Yuri Kovelenov 3 months ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #12579
    elk
    elk
    Licensee

    Hi.

    I’m trying to set up shadows for my project, but i keep getting these jagged edges. I can’t seem to find the map size in 2.8, is it controlled by some other slider or am i looking in the wrong place ? Using a sun lamp and all there is in the “Verg3D Settings” is “Shadow Size” and that should be only for the physical size of the shadow map in the scene right ? Please see attached my current setup, softness is at dafulte 3, witch i though should produce a bit of blur, also adjusted radius up a bit, but to no effect.

    Trying to set up similar settings in a new project seems to get me better results, could it be some other setting in my project messing things up ? This project has been updated through multiple Verge3D versions and pre releases as well, if that has anything to do with it.

    Attachments:
    You must be logged in to view attached files.
    #12604
    Yuri Kovelenov
    Yuri Kovelenov
    Developer

    Hi,

    Another important setting, Map Size, is located under the Render tab on the Shadows panel in Blender 2.8. By raising its value you can improve the quality (at the expense of performance).

    Founder & CEO at Soft8Soft
    LinkedIn | FB | Twitter | VK | 新浪微博

    #12607
    elk
    elk
    Licensee

    That seemed to work for the resolution, I should have tried that, but was just expecting to find it in the light settings like in 2.79.

    Edit: btw; had to change cascade size, could not find a “Map Size” …

    However i am still not getting the “blur” in the edges. I set up a new app from scratch, and using similar settings seems to be doing a good job even with smaller map size (see attached). But now i know where the settings are I can have a tweak to see if some of my settings are causing the problem. If you or anyone spot my mistake feel free to post a comment.

    Thanks for the quick reply Yuri :good:

    • This reply was modified 3 months, 1 week ago by elk elk.
    • This reply was modified 3 months, 1 week ago by elk elk.
    • This reply was modified 3 months, 1 week ago by elk elk.
    Attachments:
    You must be logged in to view attached files.
    #12680
    elk
    elk
    Licensee

    Finally got around my soft shadows not working issue. Just thought I would leave a note if someone else gets a similar problem. My workaround after testing all sorts of things was to create a new project and then append my scene into the new application blend file from the old file, moved my textures over to the new folder and everything seems to work.

    #12691
    Yuri Kovelenov
    Yuri Kovelenov
    Developer

    Yep sorry, in Blender 2.8 this is called Cascade Size :wacko:
    I’m glad you found a workaround. That was probably some non-obvious setting that affected shadows and was reset. :good:

    Founder & CEO at Soft8Soft
    LinkedIn | FB | Twitter | VK | 新浪微博

    #12739
    elk
    elk
    Licensee

    Hello again.

    It seems I am not quite rid of this issue yet. I separated my file into two scenes, one for rendering and one for Verge3D, and when i appended just the Verge3D scene into a fresh .blend file of a newly created app it worked fine. But today i wanted to append my render scene to the same file (just to keep my entire workflow in one place), but that made the jagged shadows issue come back. Removing the just imported (rendering) scene fixed it again, so i checked the console log…

    Exporting with my verge scene active while the rendering scene also in the file would produce a lot more output in the console, I thought the export only would consider the current scene ? after all , only objects from the current selected scene seems to show up in the selectors in puzzles. And i don’t think anything should get linked back up when i append one scene at a time …

    Anyway, i noticed a error in the export when i have both scenes in the file, (se attached). Could this be some part of the problem? the error message is a bit non-descriptive …

    • This reply was modified 3 months ago by elk elk.
    Attachments:
    You must be logged in to view attached files.
    #12752
    Yuri Kovelenov
    Yuri Kovelenov
    Developer

    Hmm, interesting. Perhaps you could try to isolate this issue and attach some files for us to take a look?

    Founder & CEO at Soft8Soft
    LinkedIn | FB | Twitter | VK | 新浪微博

    #12753
    elk
    elk
    Licensee

    I will try to minimize the file and attach. I suspect it might be a blender beta issue, and the fact that the file has been through quite some versions of the beta by now.

    The “ERROR: Invalid count 0” did not give you a clue either ? <– this seems to be some of the cameras from the other scene, I just found out …

    I will try to have a file ready for you later tonight.

    • This reply was modified 3 months ago by elk elk.
    • This reply was modified 3 months ago by elk elk.
    #12786
    elk
    elk
    Licensee

    So i did some more digging and managed to reproduce the bug in a new app/blend file (see attached).

    So the problem seems to be that both scenes are exported i guess, and what ever scene is the “dominant”/last(?) scene will dictate the settings. I guess things might just get overwritten so whatever is last in line will win.

    The file contains two scenes, almost identical. One is set to Basic and one to Soft PCF for map type, but no mater what scene i export the settings from one gets used ( the one called Basic in my example). Just copy it to a new app or set it up from scratch for yourself to try it out.

    I made an extrusion on the plane in one of the scenes, but objects and verts seem the same in the console log no matter what scene i export, this was what lead me to think that the whole file may be exported not just the active scene. I assume this is not the way it is meant to behave.

    So my workaround for now is setting the Verge3D render settings up in my Cycles Scene.

    I guess this might be tied to my otter issues with the exporter from this thread;

    Exporting scenes

    I know this might be tied in to the revamp of the whole outline sceneGraph thingi, but if there is any way to get export to respect scenes it would be really great.

    Really appreciate you taking a look at this, and please let me know if you need further details.

    • This reply was modified 3 months ago by elk elk.
    • This reply was modified 3 months ago by elk elk.
    Attachments:
    You must be logged in to view attached files.
    #12807
    Yuri Kovelenov
    Yuri Kovelenov
    Developer

    Thank you for isolating the issue and for detailed descriptions. We’ll take a look at this. :good:

    Founder & CEO at Soft8Soft
    LinkedIn | FB | Twitter | VK | 新浪微博

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.