We use cookies to ensure that we give you the best experience on our website. If you continue to use this site we will assume that you are happy with it.

Problems with multiple Objects and Exploded View

Home Forums Graphics / 3ds Max Problems with multiple Objects and Exploded View

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #31449

    Hi there,
    we have some problems with our animation from 3dsmax 2020.
    We want to show an exploded view of an engine block. In order to do that we use a dummy and link it to the objects with “inherit scale” checked off.
    This works in 3ds max perfectly but in Verge3d the objects are scaled anyway (but only in one axis – see screenshot)

    Our only solution to this problem so far is to export as fbx and bake the animation.

    This brings me to the next question:
    Is there another way to stop an animation for a lot of objects (the final engine has hundreds of “flying” and moving parts)?
    Grouping does not work, as the animation is gone afterwards. Selection Sets are not recognized by Verge3d…
    I tried naming the objects with “Explode…” but I do not know how to select objects by name with a prefix in order to start and stop the animation.
    (sorry i am no programmer)

    Attachments:
    You must be logged in to view attached files.
    #31452

    Hi Michael,

    This works in 3ds max perfectly but in Verge3d the objects are scaled anyway (but only in one axis – see screenshot)

    This looks like a bug, can you provide a test case to reproduce it?

    Grouping does not work, as the animation is gone afterwards.

    That’s strange because grouping is supported in verge3d. We also use it control animations in some of our demos. Check out the Farmers Journey application in the SDK. There should be a group called “farmer_armature_group” and it’s used in the app’s puzzles logic like this:
    farmer_armature_group.png

    Selection Sets are not recognized by Verge3d…

    You are right, selection sets are not supported.

    Attachments:
    You must be logged in to view attached files.

    Co-founder and lead developer at Soft8Soft.

    #31455

    Hi Ivan,
    I attached a small version of my engine for you.

    2 problems arrise here:
    – inherit scale (checked off in 3ds max) is ignored in verge3d
    see squashed objects in verge3d.
    – the piston animation is not as in the 3ds max file – the pistons are moving at the same time in verge3d. This may be, because verge3d is resetting all animtions to start at 0??

    In the meantime I also tried using the Dummy from 3ds max and scale it in verge3d itself, so I do not need an animation for this. This works, but with the same problem – I cannot scale the objects to explode with different settings for the different axis, as they get squashed. If scaled like 2/2/2 it works fine, the objects get “exploded” from the main engine, but I would like to divide the objects less in z(up/down).

    https://www.dropbox.com/t/9cpeJwCyXxVEHaXD

    many thanks
    Michael

    #31515

    – inherit scale (checked off in 3ds max) is ignored in verge3d
    see squashed objects in verge3d.

    Those “inherit” options are currently not supported. But this feature looks very convenient for creating exploded views, so we added it to our TODO list. As for now I think the easiest solution is to control all parts of the scheme separately via several dummy objects or bones.

    – the piston animation is not as in the 3ds max file – the pistons are moving at the same time in verge3d. This may be, because verge3d is resetting all animtions to start at 0??

    Yes, that’s the default behavior, which is more suitable for starting/stopping animations individually. So, I guess in your case you want to play the entire animation timeline the same way as it looks in 3ds max. In order to do that you need to go to Verge3D->Export Settings… and enable the “Export within playback range” option:
    playback_range.png
    – this option is analogous to baking all the animations within the scene playback range, it’s 0-170 for your scene and this also means that all animations will loop every 170 frames, so you might need to tweak that. Unfortunately, there’s a bug with that “playback range” option and it doesn’t work as expected right now. But we are planning to release an update next week which should fix it.

    Alternatively, if you do not enable “Export within playback range” then there’s a bit more tedious way: you can tweak the animation range per object by using the following options in the “Modify” tab:
    custom_range.png
    – I found out that if you set 0-50 for all engine parts then their animations loop nice and they all start at the right time.

    Attachments:
    You must be logged in to view attached files.

    Co-founder and lead developer at Soft8Soft.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.