I can not see the verge3d examples correctly

Home Forums General Questions I can not see the verge3d examples correctly

This topic contains 8 replies, has 2 voices, and was last updated by  frg 1 week, 1 day ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #10461

    frg
    Participant

    Hello everyone,first, excuse my English.

    I am starting with this tool and I have encountered a problem that I can not solve.

    I have noticed that some projects are not displayed correctly.

    I am starting with this basic tutorial:https://www.youtube.com/watch?list=PLMnTV0uuRMhRn1QomhOqH4Rt_bSlDGXbP&v=ibPSGArAfJM but I have had to abandon it because I do not understand what I must do to make the object appear as shown in the tutorial.

    It also happens with some examples of verge3d too.

    Everything looks badly lit, too dark and I do not understand why.
    I’ve tried on two different computers and the same thing happens.
    I attach two images that I hope will help you understand the problem.

    Thank you very much.

    • This topic was modified 1 week, 3 days ago by  frg.
    Attachments:
    You must be logged in to view attached files.
    #10473

    Hi!

    Sorry to hear that you’re having those issues.

    Do other Verge3D demos work for you as expected?
    What browser/OS are you using?
    Can you please visit the webgl report page and attach the screen shot of how this page looks for you? Thanks!

    Founder & CEO at Soft8Soft
    LinkedIn | FB | Twitter | VK | 新浪微博

    #10488

    frg
    Participant

    Hi, thanks for the answer.

    Do other Verge3D demos work for you as expected?
    What browser/OS are you using?

    The demonstration of the city I think it looks good and the one of the cube also, the one of the teapot heater also.

    In the example of the metalic cube with the monkey I can see that it is represented correctly but the background is always dark, when it should be gray.

    But i have problems with a simple box without texture or material.

    Finally, I found out that with the Microsoft Edge browser I have no problems.
    But I would not like to use that browser. ;)

    When I compare the result in google chrome with microsoft edge it always happens that in the latter it looks brighter.
    Attached image comparing both browsers with the teapot demonstration.

    I send you what you have asked me using the Chrome browser, the result with Microsoft Edge is the same

    I have tried two computers, the first with Windows 7 and the other with Windows 10, the browsers are updated in both and the graphics drivers are also.
    And i use the opengl version 3.3.
    My graphics cards are not powerful, they are old, 5 years old, maybe there is the problem?

    Finally, I have activated the draft extensions in chrome but it does not solve anything

    I think the problem is in the representation of the background, in the nightstand tutorial, i can not see the hdr background using chrome, but it is okey using Microsoft Edge. And that should affect the general lighting of the scene.

    I hope there is some solution. For now, I will continue advancing with Microsoft Edge.
    In any case, thank you very much.

    • This reply was modified 1 week, 2 days ago by  frg.
    • This reply was modified 1 week, 2 days ago by  frg.
    Attachments:
    You must be logged in to view attached files.
    #10497

    Hi,

    I see that you’re using Geforce 8400 GS video card which can work with WebGL only on top of older Direct3D 9 API on Windows. Unfortunately, WebGL in combination with such underlying graphics API appears to be very buggy as it is considered outdated and poorly tested by the browser vendors. :-( For this reason some advanced WebGL features/extensions may not work properly. :unsure:

    Founder & CEO at Soft8Soft
    LinkedIn | FB | Twitter | VK | 新浪微博

    #10503

    frg
    Participant

    Ok, thanks for the clarification.

    So I must understand that Microsoft Edge uses the integrated graphics card, in my case, HD Intel® 4600.

    Is it like that?

    Because it’s the only explanation I see so that everything is seen correctly in Edge.

    Thanks again

    #10504

    MS Edge works probably because it uses an alternative backend as compared to Chrome and Firefox
    https://blogs.windows.com/msedgedev/2016/06/09/open-sourcing-the-microsoft-edge-webgl-glsl-transpiler/

    Founder & CEO at Soft8Soft
    LinkedIn | FB | Twitter | VK | 新浪微博

    #10512

    frg
    Participant

    Thank you very much, Yuri

    In the computer of my home with windows 7 I have the same problem and I solved it by removing the hardware acceleration in Chrome.
    Now looks good, but the problem is a very poor performance.

    I have a laptop third generation i7 with hd intel 4000 and a graphic card nvidia geforce gt 630m.

    Luckily, I’ve been able to verify that everything is going great with Firefox. It looks good and with good performance.

    But now, when I press the sneak peek button, google chrome is launched directly. I would like this to happen without the need to convert Firefox to my default Windows browser.

    Is it possible to configure this option directly in Blender 2.79b by keeping Chrome as the default browser of windows 7?

    I have searched for information but can not find anything, apologies for asking too much.

    Thanks

    • This reply was modified 1 week, 2 days ago by  frg.
    • This reply was modified 1 week, 2 days ago by  frg.
    #10516

    You can try to set FF as default browser for Verge3D by using webbrowser.register() method. You can use it in the exec_browser function inside the addons/verge3d/custom_ui.py script.

    Founder & CEO at Soft8Soft
    LinkedIn | FB | Twitter | VK | 新浪微博

    #10522

    frg
    Participant

    Thank you very much! :)

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.