We use cookies to ensure that we give you the best experience on our website. If you continue to use this site we will assume that you are happy with it.

camera only rotate

Home Forums Graphics / Blender camera only rotate

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #42748
    1simone
    Participant

    I have the room which is inside a room.
    clicking on an object moves it.
    the problem is that I want to block all its movements leaving only the rotation. how can I do?

    #42751
    xeon
    Customer

    ok…I am a little uncertain of what you are wanting to do based on the title of the post and what you have written in it.

    Answer based on Title of post:
    To limit your camera to an orbit in Blender….select your camera. Select Object Data Properties (the camera icon) and make the following settings:
    1. Controls: Orbit
    2. “Allow Panning”: unselected
    3. If you want to disable zoom. set your min and max distance.

    Answer based on body of post
    Select the object
    Select Object Constraint Properties > Add Object Constraint
    Select Limit Location and check min and max all set to current location.

    Xeon
    Route 66 Digital
    Interactive Solutions

    #42752
    1simone
    Participant

    sorry, i meant camera inside a room.
    In practice, to move around the room, I click on an object and the camera moves to a precise point.
    when the room has moved, I have to fre so that the user can turn around without being able to leave the room.
    thank you

    #42805
    xeon
    Customer

    The first set of instructions will allow you to do what you want. Se up Orbit, turn off Allow Panning and set the min and max zoom and you will be good.

    Xeon
    Route 66 Digital
    Interactive Solutions

    #42810
    1simone
    Participant

    xeon: many thanks!
    Simone

    #43062
    1simone
    Participant

    Hi master, I created the scene and placed the room. I assigned a target and some invisible objects and clicking the camera is placed correctly. but I do not understand why when you open the scene, the camera is positioned in another place and seems to move without rules.
    Thanks! :wacko:

    #43065
    xeon
    Customer

    Hi there,

    I have encountered this repeatedly and dont have a great answer as to why it does this but there is a way to manage it at least.

    What I do is make sure that on Frame 0 I have my active camera view set to where I need it to be positioned. I use two empties: Cam_Loc and Cam_Target. Cam_Loc is the base position of the camera and Cam_Target is a position where I want the camera to look at. Make sure in blender your camera is positioned on these empties.

    In V3D the first puzzles to run are set Active Camera and tween Camera to Cam_Loc and Look at Cam_Target with a duration of 0.
    As long as these are first and frame 0 is set to those locations you should not get a bounce of the camera.

    I often work in blender and accidentally move the camera so I get a bounce but by making the camera puzzles first, your scene should be okay.

    Xeon
    Route 66 Digital
    Interactive Solutions

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.