struggle with animations

Home / Topic / struggle with animations

Home Forums Graphics / Blender struggle with animations

This topic contains 3 replies, has 3 voices, and was last updated by Yuri Kovelenov Yuri Kovelenov 3 months, 1 week ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #1584

    guynat
    Customer

    Hello,

    First of all congratulations on this software, I saw your presentation at blender conf and now trying the thing to see if it meets my requirements.

    I am currently struggling with animations. I can not figure out the following things :

    – why some animations play from start and some don’t : for example in the spinner example, nothing in the puzzle stops the animation when starting… while if I do a simple scene with a spinning cube, the animation will start regardless if I call animation … What am I doing wrong, do I need to animate via armatures ?

    – I simply can’t get the “play animation from X to Y” to work and do something when finished…

    I must be doing something wrong in Blender in the way I set up my animations but can not figure out what …

    Is it about actions in the Dopesheet ? Is it about animating with armatures ? Should I bake or not bake animations

    See the attached project :
    – I would like none of the animations to start. Right now I have to put an animation stop at the beginning of the script
    – On the suzanne animation it loops forever on the first 60 frames and does not execute the part in “when finished” in the puzzle

    Can you please help ?
    Thank you

    Attachments:
    You must be logged in to view attached files.
    #1586

    – why some animations play from start and some don’t : for example in the spinner example, nothing in the puzzle stops the animation when starting… while if I do a simple scene with a spinning cube, the animation will start regardless if I call animation … What am I doing wrong, do I need to animate via armatures ?

    There’s a checkbox in object’s preferences called Autostart Animation.

    – I simply can’t get the “play animation from X to Y” to work, I assume X and Y being frame numbers ? Although I can see it working like a charm in the e-learning demo…

    Must work correctly, can you make a screenshot of your puzzlez?

    I must be doing something wrong in Blender in the way I set up my animations but can not figure out what …

    Can you attach a blend file with the example?

    Is it about actions in the Dopesheet ? Is it about animating with armatures ? Should I bake or not bake animations

    Yes, you need to bake your animation using Blender Baker Tool.

    Co-founder and lead graphics specialist at Soft8Soft.

    #1587

    guynat
    Customer

    Thank you for the very quick response…
    I found the verge3d section in the object panel… and everything was there.

    So I guess one question left, can you pause an animation ? I noticed stop and start gets it to restart from the beginning

    #1589

    Hi,

    thanks to your feedback we have implemented the missing pause and resume puzzles. If you’d like to you can try them in the developer preview of Verge3D and see if it works for you (replace Puzzles runtime with the attached file).

    Attachments:
    You must be logged in to view attached files.

    Founder & CEO at Soft8Soft. Creator of Verge3D and Blend4Web.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.