We use cookies to ensure that we give you the best experience on our website. If you continue to use this site we will assume that you are happy with it.

Home Forums Bug Reports and Feature Requests Reporting an issue with Verge3D

Viewing 15 posts - 31 through 45 (of 50 total)
  • Author
    Posts
  • #32623

    Hi,

    Besides the mentioned console messages (that are noncritical warnings), are there any problems observed (rendering, etc)?

    3D Verger, the CEO
    LinkedIn | FB | Twitter | VK | 新浪微博

    #32629
    xeon
    Customer

    Hi,
    There appear to be no rendering or functional issues. In evaluating Verge as a tool we can use for commercial applications for some of our clients these non-critical errors will cause us not to use MAYA or more than likely Verge3D.

    For most of our commercial work, our clients require a code review with their IT teams before anything can be hosted in their environments. These non-critical errors would be demanded by the clients to be fixed before we were allowed to deploy the code.

    So although they dont produce a fatal error…its pretty fatal to us since we can’t seem to get rid of it.

    The only solution and not a good one is for us to build in MAYA…export to Blender and build the verge apps in Blender. An extra step we hope we can avoid in the next build for sure.

    Xeon
    Route 66 Digital
    Interactive Solutions

    #32634

    Hi,

    These are purely logging messages that unfortunately are out of our control. Particularly, the first message “v3d.WebGLRenderer: KHR_parallel_shader_compile extension not supported” cannot be disabled since it is thrown by the browser internals.

    There may be printed other messages of various kind depending on operating system, drivers and hardware. Perhaps you could explain this to your client’s IT team. :unsure:

    3D Verger, the CEO
    LinkedIn | FB | Twitter | VK | 新浪微博

    #36969
    ddunston
    Customer

    Hello,

    I am having trouble with the render from Blender (2.83) to Verge3D (3.50).

    I am using Microsoft Edge:

    Microsoft EdgeHTML 18.19041
    Microsoft Edge 44.19041.423.0

    I followed this tutorial to create an Beacon:

    I’ve attached how the beacon looks in Blender and how it renders in Verge3D. The animation works, but not the light material and you can see the difference in how the model renders.

    Attachments:
    You must be logged in to view attached files.
    #36974

    You have a sub modifier on the object, but it’s not applied automatically on export, you need to apply it manually or set Bake Modifiers in Verge3D settings of Render Settings panel.

    Co-founder and lead graphics specialist at Soft8Soft.

    #36976
    ddunston
    Customer

    Thank you! Applying the submodifier worked. I’ll make note to check that next time.

    The problem I have now is that the material is not picking up the glass effect and the light doesn’t shine through.

    I can’t find this setting which may resolve it “Bake Modifiers in Verge3D settings of Render Settings.”

    Update: 12/31/2020 I tried adding the material to the beacon shape and the material to the light spinner inside using the visual code blocks and it doesn’t work.

    • This reply was modified 8 months, 3 weeks ago by ddunston.
    Attachments:
    You must be logged in to view attached files.
    #37012

    Hi,

    you should probably enable transparency for your material.

    3D Verger, the CEO
    LinkedIn | FB | Twitter | VK | 新浪微博

    #37020
    ddunston
    Customer

    Hello,

    I did enable transparency using Alpha Blend and changing the Alpha level.  That worked and I could see the spinner inside the 3D model within Verge3D.

    However, the “Emission” surface is not working on the spinner.  I have the setting set to white and the strength set to 100.  The spinner does not show the Emission material.  It is dull.

    I also tried adding in a point light and changed it red and that doesn’t display at all.  I tried playing with the new light puzzle filters on the point light and nothing happens.
    -duane

    Attachments:
    You must be logged in to view attached files.
    #37221

    Try to enable HDRI rendering in Verge3D settings in Render Tab.

    Co-founder and lead graphics specialist at Soft8Soft.

    #37367
    ddunston
    Customer

    Sorry for the late reply. I do not see that option and looked at the documentation and don’t see the option to enable HDRI renderings.

    #37371

    It’s here:

    Attachments:
    You must be logged in to view attached files.

    Co-founder and lead graphics specialist at Soft8Soft.

    #37392
    ddunston
    Customer

    That didn’t work either. I’m going to work on an alternative solution. Thank you for your assistance.

    #37397

    Here’s an example for you with solution.

    Attachments:
    You must be logged in to view attached files.

    Co-founder and lead graphics specialist at Soft8Soft.

    #38187
    winacecilia03
    Participant

    i tried to uploading my file in app manager, but it always 12%. And after i waitting for about 1 hour, it error. how to fix it??

    Attachments:
    You must be logged in to view attached files.
    #38193

    Hi,

    how large is your app? also may be it was a network connection error?

    3D Verger, the CEO
    LinkedIn | FB | Twitter | VK | 新浪微博

Viewing 15 posts - 31 through 45 (of 50 total)
  • You must be logged in to reply to this topic.