We use cookies to ensure that we give you the best experience on our website. If you continue to use this site we will assume that you are happy with it.

Puzzle not loading on Chrome/android

Home Forums Puzzles Puzzle not loading on Chrome/android

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #37029
    Avatarnadar
    Participant

    Hello guys. Happy new year
    I’m a 100% newcomer in Blender (and web editing in general…)

    https://cdn.soft8soft.com/AROAJSY2GOEHMOFUVPIOE:fd93620d1f/applications/_Tata Kouaba 4/_Tata Kouaba 4.html

    I developed a project in Blender and added some interactivity with Puzzles (mainly annotations).
    Everything works fine on Windows, but when used on an android platform, the puzzle animation do not work.
    I tried opening “Swiss army knife” on the same android device, and it worked fine.
    So, I suppose there is something wrong with my development. Something wrong with special characters in naming ? Any suggestion will be appreciated. Thanks

    • This topic was modified 3 months, 1 week ago by Avatarnadar.
    • This topic was modified 3 months, 1 week ago by Avatarnadar.
    #37033

    Hi,

    nice looking app! sometimes the annotations disappear on desktop too when I zoom the camera. May be you are using some camera-related logic that affect the annotations?

    Also, the app is too big – it loads more than 100 Mb of assets, mostly textures. You must optimize it!

    3D Verger, the CEO
    LinkedIn | FB | Twitter | VK | 新浪微博

    #37034
    Avatarnadar
    Participant

    Thanks a lot for this immediate answer !
    I reduced the size of the loaded textures to 25% of the original size. The visual quality is slightly reduced, but still acceptable (at least to be viewed on a smartphone). The assets are now approx. 30 Mb. Is this too much ?
    Unfortunately, the problem is still the same: puzzle related interactivity is not working on android device.
    Could you please be more explicit about possible problems related to camera logic ? I’m only using the camera position to initiate the starting point of view. Should I use it more ?

    #37035

    Hi,

    I believe the issue is happening since you’re using “on hover” puzzle which can’t be supported on touchscreen-based devices such as mobiles.

    Co-founder and CTO at Soft8Soft
    FB | Twitter | VK

    #37037
    Avatarnadar
    Participant

    Thanks for the suggestion.
    Other puzzle commands (“hide”, “when clicked”) are not working either.
    Find attached the puzzle I’m using. Something wrong with it ?

    Attachments:
    You must be logged in to view attached files.
    #37213

    Hi,

    are you still experiencing this issue?

    3D Verger, the CEO
    LinkedIn | FB | Twitter | VK | 新浪微博

    #38544
    Avatarmarkob
    Customer

    I have the same problem. I cant rotate and click on objets to run animations. Only buttons works.

    https://cdn.soft8soft.com/AROAJSY2GOEHMOFUVPIOE:ba442c63f8/applications/StrukeljTest/StrukeljTest.html

    #38548
    Avatarnadar
    Participant

    Can you post the corresponding puzzle ?

    #39020
    Avatarmarkob
    Customer

    Here is xml.
    Only html buttons works.

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.