Oculus Quest Support?

Home Forums General Questions Oculus Quest Support?

Tagged: , ,

This topic contains 12 replies, has 4 voices, and was last updated by Avatar synbenfoulds 2 months ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
  • #14899

    Hi all,

    Is there any information available yet whether it’ll be possible to play Verge3D apps on the Oculus Quest? Sounds like the device is going to be quite restricted in terms of playable content compared to the Rift, but I’m hoping it comes with a browser of some sort that might be used to play custom apps? Maybe wishful thinking…

    • This topic was modified 6 months, 2 weeks ago by Avatar synbenfoulds.
    Yuri Kovelenov
    Yuri Kovelenov

    Haven’t tried that device ourselves yet, but I think WebVR works there as three.js/a-frame is known to work on it.

    3D Verger, the CEO
    LinkedIn | FB | Twitter | VK | 新浪微博


    Hi Yuri, thanks for the reply. I had a very quick go with a Quest yesterday and was able to play the Xmas VR demo on it via the Oculus browser, so all looking promising!


    Seems it’s just look interaction for now on the Quest – no controller ray cast as yet


    Hi, just revisiting this with the new version of Verge coming out – are there any plans to fully the Oculus Quest controllers in this version? Ray casts etc. Excited to start making full use of the Quest and Verge!

    Many thanks


    Hi, we plan to support all VR controllers available on the market, although with limited capabilities such as one-button operation and raycasting for now. We invite you to test the upcoming Verge3d 2.14 pre-release and share your experience!

    Co-founder and CTO at Soft8Soft
    FB | Twitter | VK


    Hi Alexander, thanks that sounds great. Looking forward to the pre-release in that case!


    OK I’ve had a go with 2.14.0pre2 on the Quest

    Ray trace works from the right hand controller (no visible trace from left) and handles whenhovered events which is great.

    Doesn’t seem to recognise any button presses though – tried all buttons, triggers, thumbsticks but no input seems to work with the whenclicked test I set up (tried with mouse and it works with that). Any idea which of the buttons is meant to be supported? Thanks.


    Hi, support for the second controller is on the way (scheduled for 2.14 release). As for buttons/thumbsticks, for now it’s only possible to assign events on these using JavaScript.

    Co-founder and CTO at Soft8Soft
    FB | Twitter | VK


    EDIT: Sorry that’s me being dumb – was trying to use whenclicked instead of onsessionevent for the controller button, hence it not working! Very much a newbie at all of this, but all seems to be working great and thanks again for all the work you guys are putting in.

    • This reply was modified 3 months, 3 weeks ago by Avatar synbenfoulds.
    • This reply was modified 3 months, 3 weeks ago by Avatar synbenfoulds.

    Cool, glad you worked it out! :good:

    Co-founder and CTO at Soft8Soft
    FB | Twitter | VK


    Hallo Synbenfoulds, how did you add the Christmas App to Oculus Browser? I have Oculus Rift S but I do not know how to see it. Thanks for help ;)


    Hi Abin,

    I think I just went to soft8soft.com and browsed to the app via the gallery (the button at the top that says “Made with Verge3D”)

    That took me to the following page:

    Will test it again when I get chance and let you know if I did it any differently…

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.