We use cookies to ensure that we give you the best experience on our website. If you continue to use this site we will assume that you are happy with it.

Messed up scale and orientation of animated objects

Home Forums General Questions Messed up scale and orientation of animated objects

Tagged: 

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #43286
    kevin
    Participant

    Hello,

    I have a PCB in blender with some components emerging from the board in a nice animation. It plays fine in blender but once exported to gltf or previewed with sneak peak, the animated objects are 100x larger and rotated wrongly.

    The blender file is 70 MB, too big to attach, so here’s a drive link https://drive.google.com/file/d/1_EEDhJRV2hFEmPGMIxntWwB_rOEWXLMm/view?usp=sharing

    Many thanks.

    #43304

    It’s hapens because of delta transfroms that are not supported. If you set them to 1/1/1 in scale you will see the same in blender.

    Attachments:
    You must be logged in to view attached files.

    Co-founder and lead graphics specialist at Soft8Soft.

    #43311
    kevin
    Participant

    Hi Mikhail,

    Thanks for pointing this out to me. I was lucky enough to find this code https://blender.stackexchange.com/questions/145857/how-do-i-apply-delta-transforms-to-normal-transform and convert all the delta transforms to standard transforms, and with a lot of tweaking I managed to get the same animation. However when played in Verge3D all animated objects are moved to the world origin.

    File: https://drive.google.com/file/d/1VrMiUucI5Vuf7wxhNu8kPyfjQWNde5Vx/view?usp=sharing

    I appreciate your time.

    Kevin

    #43320

    You need to set keyframes for all x,y,z for location. If animation exist all not set coordinates will be set to 0 on export.

    Co-founder and lead graphics specialist at Soft8Soft.

    #43327
    kevin
    Participant

    Thanks for the tip, problem fixed. Just one more thing: When opened in Verge3D the animation of my collections ‘first front’, ‘second front’ and ‘third front’ are completely skipped, both in .gltf and .html. I have not restricted the frames in puzzles (https://imgur.com/a/AqoQZIb)

    The same occurs in the viewport when I open puzzles. However very strangely when I let the viewport finish then click ‘run your puzzles’ it starts from the beginning as it should.

    Blender file: https://drive.google.com/file/d/1vI2UL51CmjkQhivxDnle9GJ0OGkVUc-1/view?usp=sharing

    Thanks so much man. Your help is invaluable.

    #43351
    kevin
    Participant

    Hi Mikhail, I was able to solve this by adding a .1 second delay to the animation in puzzles. I’m happy to say that I’ve finished my product. My supervisor will buy a license. Some things I’d like to mention:

    -Had to turn off autostart and set looping to ‘once’ for every single object, in object properties. This wasn’t so bad since I set up a macro and left it running. If I’m not missing a feature, it would be nice to be able to turn off autostart and looping for all objects in a scene at once.

    -Encountered issue where annotations would drop FPS down to around 3. Turning off ‘fade annotations’ in initialization fixed this completely.

    -Upon creating ‘when clicked’ puzzles, clicking with M1, M2 or middle mouse anywhere to pan or rotate would cause a half-second freeze (lag spike). Work around for me was to turn on ‘double click/tap’ in advanced event options.
    (I’m not using html buttons because webflow embedding is not free).

    You are welcome to point out any potential fps improvements to make, shared folder is entire Verge3D app: https://drive.google.com/drive/folders/138u7_d8L3puA-QAercuSnornbyQU9uA_?usp=sharing

    Thanks for the help. Have a nice weekend :good:

    #43372

    Encountered issue where annotations would drop FPS down to around 3. Turning off ‘fade annotations’ in initialization fixed this completely.

    -Upon creating ‘when clicked’ puzzles, clicking with M1, M2 or middle mouse anywhere to pan or rotate would cause a half-second freeze (lag spike). Work around for me was to turn on ‘double click/tap’ in advanced event options.
    (I’m not using html buttons because webflow embedding is not free).

    This all happens because amount of object about 4350 – this is extremely huge amount, especially for animated objects. Try to keep them under 100 objects for scene and less that 300-500k amount of polygons (for the whole scene), not the 2.5 million.

    Co-founder and lead graphics specialist at Soft8Soft.

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.