We use cookies to ensure that we give you the best experience on our website. If you continue to use this site we will assume that you are happy with it.

mesh distortion armature & shapekey

Home Forums Graphics / Blender mesh distortion armature & shapekey

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #28720
    g_hug
    Customer

    I have 5 shapekeys keyframed on a mesh and simultaneous armature movement. It works ok in Blender. Is there a way for this to work in Verge3d without the mesh distorting? Is it to do with the ‘bake armature actions’, or perhaps with whether the armature animation has been pushed to an nla track?
    Thanks!

    file here:

    • This topic was modified 2 years, 5 months ago by g_hug.
    • This topic was modified 2 years, 5 months ago by g_hug.
    #28724

    I have 5 shapekeys keyframed on a mesh and simultaneous armature movement. It works ok in Blender. Is there a way for this to work in Verge3d without the mesh distorting? Is it to do with the ‘bake armature actions’, or perhaps with whether the armature animation has been pushed to an nla track?
    Thanks!

    Yes, but you need to remake skinnig so each vertex has only 4 weight. Now there’s about 6-7 weight per vertex. Limit is only 4.

    Attachments:
    You must be logged in to view attached files.

    Co-founder and lead graphics specialist at Soft8Soft.

    #28726
    g_hug
    Customer

    Yes, but you need to remake skinnig so each vertex has only 4 weight. Now there’s about 6-7 weight per vertex. Limit is only 4.

    Amazing, thank you! any advised resources for this?

    #28728

    thank you! any advised resources for this?

    I think theese reccomendations must be enougth.

    Co-founder and lead graphics specialist at Soft8Soft.

    #28731
    g_hug
    Customer

    ok fair enough! thanks for the help with things these past days

    #28738
    g_hug
    Customer

    for anyone also looking at this, there’s a function for limiting this in the weight paint mode with all vertices selected, in the ‘weights’ option, then ‘limit total’

    #28787

    :good:

    Chief 3D Verger | LinkedIn | Twitter

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.