We use cookies to ensure that we give you the best experience on our website. If you continue to use this site we will assume that you are happy with it.

GLTF 2 material problem with color correction

Home Forums Graphics / 3ds Max GLTF 2 material problem with color correction

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #38086
    vklein
    Customer

    Hello,

    in 3dsmax by checking GlTF 2.0 complient material Verge creates a “occlusion_roughness_metallic_ID.png” map from the 3 input maps. The problem is it takes the base maps circumventing color correction nodes and import gamma settings of the map (inside the open bitmap dialog, lower left)between the base maps and the Physical material. In real PBR workflow occlusion, roughness and metallic maps MUST be read linear instead of gamma corrected so I need a color correction putting gamma 2,2 in between the three maps (correct in linear) and the material (forcing 3dsmax and Verge to correct the maps). Verge ignores it on export together with any output settings of the maps (like the Color map graph or simply “output amount”)

    Objects turns out too glossy mainly because of the way too dark wrong roughness map.

    1. Please fix this and let Verge bake the outputs of the graph for every map instead of cheating and taking the original maps.

    2. At least let Verge use the gamma settings of the bitmap

    3. Reevaluate your understanding of gamma corrected / linear usage of maps for PBR workflow.

    For now I have to raise gamma on the final “occlusion_roughness_metallic_ID.png” after export which is unlucky to say the least.

    #38259

    Can you share your example with textures where you get the wrong result?

    Co-founder and lead graphics specialist at Soft8Soft.

    #38287
    vklein
    Customer

    A test scene here:

    https://download.mediaprojekt.eu/index.php/s/JrD5gqHzTLayXWd

    the roughness map is read with default gamma (in file dialog automatic) which is corrected with a Color Correction. The resulting combined ao-metallic-rouch map from Verge after export looks like the input not like the color correction. And yes 3ds max is ignoring it in the display too.

    This is the look it should have after I manually Gamma corrected the Verge exported combined texture with a 2,2 gamma, much rougher everything:

    https://www.mediaprojekt.tv/show/verge/WSW_Teil/WSW_Teil.html

    • This reply was modified 1 year, 6 months ago by vklein.
    #38324

    Seems there some bugs, will fix it in some of the next releases, I hope.

    Co-founder and lead graphics specialist at Soft8Soft.

    #38420
    vklein
    Customer

    Thanks a lot. It a whole node baking in this case is too much or 3dsmax defies a clear/right solution (3dsmax file gamma handling isn’t always sane) at least a Verge texture parameter like “linearize map” or “use linear” telling Verge to use that particular texture different would help at lot too. But yes a right whole material node tree evaluation prior to baking would be the right solution.

    #38427
    vklein
    Customer

    I just saw that you officially don’t support advanced settings in Color Correction node which I used to change the gamma. Then I of cause can’t blame you for ignoring it. Then at least a “linear” checkbox in texture properties become even more reasonable solution.

    #38429

    You can choose linear space for image in open dialog.

    Attachments:
    You must be logged in to view attached files.

    Co-founder and lead graphics specialist at Soft8Soft.

    #38652

    Indeed, glTF-compatible materials are very basic by their nature. Color correction, gamma, ramps etc are not supported.

    Verge3D’s Tech Chief
    FB | Twitter | VK

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.