We use cookies to ensure that we give you the best experience on our website. If you continue to use this site we will assume that you are happy with it.

Enabling shadows makes blank screen (both sneak peek and pub)

Home Forums Bug Reports and Feature Requests Enabling shadows makes blank screen (both sneak peek and pub)

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #8686
    tcdoe
    Customer

    Hi,
    (note i’m using v2.9 if that matters, but this also happens on 2.8)

    Ok I followed the shadow tutorial very carefully. This is my first time trying for a shadow. At first, I got weird solid things like square with circle-hole, etc.

    I turned off ALL shadows for all individual lamps and the sun.

    I checked the ‘Enable Shadows’ checkbox. The preview appears and it looks ok, but of course no shadows.

    Then I turn on shadows for ONE lamp. I hit ‘sneak peek’ and all I get is my grey background and the full-screen icon. That’s it completely blank. I’ve carefully made sure it’s not a cache problem. Also I tried other lamps, and as long as one is on, then it’s just a blank result.

    I don’t know what to do from here. Stumped. I tried all the different settings Basic, PCF, Soft PCF but no luck, just blank page.

    Here is a link to my project directory zipped if needed. Please do not distribute. The password is vergeabem01.
    https://drive.google.com/file/d/1Optz3eptJJk0JpsvfHFkVA4-HLjcUJg3/view?usp=sharing

    Thx. T.

    • This topic was modified 3 years, 9 months ago by wpadm. Reason: moved to Bug Reports

    CEO, ABĒMIS LLC
    visit: abemis.com

    #8709

    Hi,

    We tried exporting your file and indeed, it crashes on one of our computers. If you open the browser console (which is always a good idea when something goes wrong), do you see MAX_TEXTURE errors as in the attached screenshot?

    Looking in your file, I see many light sources, too many for use in a WebGL scene. Each of them requires using a texture unit under the hood, so your scene exceeds the hardware limit. I’d recommend keeping the number of lights below 8 at least (ideally 2-3) otherwise your scene won’t work on low-end computers and iOS devices.

    Attachments:
    You must be logged in to view attached files.

    Chief 3D Verger | LinkedIn | Twitter

    #8712
    tcdoe
    Customer

    Hi Ok thanks for the info. You might want to include that information about # of light source limits for people who are new to this.
    I’ll try reducing, looking at console, and see what happens.

    CEO, ABĒMIS LLC
    visit: abemis.com

    #8786
    tcdoe
    Customer

    Hi,
    Unfortunately it did not work. I can’t get shadows. I CAN see some kind of shadow-thing happening. If you rotate the scene (not in Blender, but on the generated webpage) until you are looking top-down, you’ll see some hard-shadows of just the text ‘flashing-by’.

    I’ve reduced the number of lights to only three point sources. I tried many permutations such as using spotlight source but nothing changes.

    At least now it’s not just a blank page.

    I’m guessing there might be some problem with how I’m assigning the Verge light parameters e.g. FOV, near-far, etc.
    Please take a look at that (linked below) and see if you find any obvious (to you) mistakes. I’m not sure how to set a FOV for a point light source.

    Note again that I’m using 2.9 here but I tried going back to 2.8 and the same thing.

    Here is zipped file of my work directory updated: pword is vergeabem02.
    https://drive.google.com/file/d/1CQ52IH40EX6VkdfkFY960_bP2V2uqV0L/view?usp=sharing

    If anyone else here in the community wants to download/check it please feel free! but I ask that you don’t distribute. Thx.

    Best, T.

    • This reply was modified 4 years ago by tcdoe.

    CEO, ABĒMIS LLC
    visit: abemis.com

    #8788

    If anyone else here in the community wants to download/check it please feel free! but I ask that you don’t distribute. Thx.

    There’s two buggs for now: 1- point light not working with shadows so better to use spot or sun 2 – to get shadows for spot you need at first to switch to the Internal Render in shadow settings of the spot set Ray Shadow and then switch to cycles and you will get the shadows.

    Co-founder and lead graphics specialist at Soft8Soft.

    #8891
    tcdoe
    Customer

    Great thanks, I’ll tryout.

    note that in your info/manuals it says that point lights do work with shadows. Maybe I misunderstand or missed something.

    So just to be sure, in 4.8 or 4.9 point lights DO NOT work with shadows.

    Also, I’ve found that ‘enabling screen capture’ in the INIT crashes my brand new android tablet (back to blank). It’s not a giant problem but you’all should know.

    • This reply was modified 4 years ago by tcdoe.

    CEO, ABĒMIS LLC
    visit: abemis.com

    #8897

    note that in your info/manuals it says that point lights do work with shadows.

    As i said it’s a bug that we missed I think a long time ago, it’s must work but it broke in one of the earlier versions, we already fix that and it will come in the next release (or pre-release).

    Also, I’ve found that ‘enabling screen capture’ in the INIT crashes my brand new android tablet (back to blank). It’s not a giant problem but you’all should know.

    Ok, thanks we’ll look at it.

    Co-founder and lead graphics specialist at Soft8Soft.

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.