We use cookies to ensure that we give you the best experience on our website. If you continue to use this site we will assume that you are happy with it.

alpha blending issue

Home Forums Bug Reports and Feature Requests alpha blending issue

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #57932
    kdv77kdv
    Participant

    See the picture: a nearly transparent plane is whown white and covers all other objects with alpha blending. Opaque objects are not affected.

    #57954
    xeon
    Customer

    Just curious if you are disabling the depth write (aka no depth writes).
    If not may want to give that a shot?

    Xeon
    Route 66 Digital
    Interactive Solutions - https://www.r66d.com

    #57965
    xeon
    Customer

    Just tried a few things and the only thing I could do to recreate the issue was to have backface culling unchecked (off).

    Attached is a blend file with three walls with alpha blend and one opaque. As long as back-face culling is on…it seems to work…but you will have to check your application needs.

    Attachments:
    You must be logged in to view attached files.

    Xeon
    Route 66 Digital
    Interactive Solutions - https://www.r66d.com

    #57970
    xeon
    Customer

    blend file

    Attachments:
    You must be logged in to view attached files.

    Xeon
    Route 66 Digital
    Interactive Solutions - https://www.r66d.com

    #58304

    Hi, perhaps this is typical case with alpha sorting. Transparent plane rendered before all other transparent objects and thus prevent them from being rendered. Try to increase the render order property for this plane.

    Verge3D’s Tech Chief
    FB | Twitter | VK

    #58309
    kdv77kdv
    Participant

    I can’t change renderOrder for those walls. they are equal and must hide some objects behind them (not all).

    In ideal, I want to get this picture, but without alphaToCoverage = true. It works perfect in Chrome but looks dithered on Android and takes a little more CPU/GPU time affecting FPS.

    The only way I see for now is making objects non-transparent if they have the opacity 1. Or change their renderOrder to 0 when they are opaque …

    to recreate the issue was to have backface culling unchecked (off)

    In my case this has no infuence. Verge3D materials have no such parameter…

    #58313

    We’re currently working on implementing various order-independent transparency techniques in Verge3D (depth peeling, weighted average etc). Hopefully, we will be able to provide a solution for such use cases soon!

    Verge3D’s Tech Chief
    FB | Twitter | VK

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.