Why do I get different behavior depending on the mode I'm in when I preview?

Home Forums General Questions Why do I get different behavior depending on the mode I'm in when I preview?

This topic contains 2 replies, has 2 voices, and was last updated by  Blend4Life 2 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #8105

    Blend4Life
    Participant

    Hey guys,

    I made two materials: A non-node material and a PBR material. I set Environment Lighting to 0.5 in Verge3D/Internal mode and “World->Use Nodes->Background->Strength” to 0.5 in Cycles mode. I activated shadows with the default options and have a default Sun lamp.

    This is what I get when I sneak-peek the scene in Verge3D/Internal mode. There is equal shadow on both materials:

    This is what I get when I sneak-peek the scene in Cycles mode. Environment Lighting is zero and I get no light in the shadow area of the non-node material. It remains black regardless of how high I set Cycles’ world strength – only the PBR material reacts to this parameter.

    • This topic was modified 2 months ago by  Blend4Life.
    • This topic was modified 2 months ago by  Blend4Life.
    #8109

    Internal and Cycles material not compatible, use only Cycles or only Internal. Internal world will effect only Internal materials, Cycles world will effect only Cycles materials (pbr shader too). If the vehavior is different, then post it in Bug Reports and Feature Requests forum as a bug, please.

    Co-founder and lead graphics specialist at Soft8Soft.

    #8114

    Blend4Life
    Participant

    Oh, okay. I’ll stick with the Cycles world then since Internal will go extinct anyway soon. Thanks, Mikhail!

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.