We use cookies to ensure that we give you the best experience on our website. If you continue to use this site we will assume that you are happy with it.

Weird issue with shadows and hovering

Home Forums Bug Reports and Feature Requests Weird issue with shadows and hovering


Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #15037

    Hello Guys,

    I hope everything went great with the event in the Netherlands! I wish I could have been there!

    I’ve updated verge3D to the latest version last Saturday morning, along with the latest version of Blender, and I’ve started to get a strange behavior with the cast shadows. Our customization app does execute a set of steps in sequence based on user interaction. For example, highlight affected object, rotate camera to point to target, then change the object material. Since Saturday, I noticed that when doing some of these steps, the cast shadows for the objects were being hidden, and appeared again when the sequence was complete.

    The same objects would show an outline when hovering over them, and I noticed that the shadows were hidden when hovering over the objects as well (when you hover out, the shadows show up again). I’ve reduced the project I’m working with to the very minimum, and I’m attaching the files here.

    I’ve tested this with Windows 10, with both Chrome 74 and Firefox 67. Same results in both. I’m using both blender and verge3d downloaded on Sat. 25th. And my computer includes a GeForce GTX 1060.

    I’m using the App Manager to test this currently, and the page says “Version 2.12.4”.

    I know for sure that this was working correctly in version 2.10.0 (unfortunately, I made a mistake and forgot to update all the files with the manager when doing the intermediate updates from that version (both verge3D and blender), so I cannot say for sure if this was already happening before 2.12.4)

    I hope the example is clear enough. Just hover over the bed, and you will see the shadows disapear, when it should show an outline around the bed instead. By the way, the only puzzles I have right now are in the Outlines tab, and it is just a “when hover” event that enables/disables the outline effect (by collection name).

    Any help is very welcome! Thank you!


    Hello again. Some more info: this seems to be related to the “enable outline” puzzle. I’ve tried to change it to affect individual meshes instead of collections, and it does the same thing. Instead of showing the outline effect, it hides everything BUT the object you enable the outline for. So, when I did it for the BEDS collection, the only thing visible around it was the cast shadows on the floor, which is what got hidden. If I do the enable outline for one of the individual objects, say, the “color-frame”, it hides “everything surrounding it”. Really puzzling (no pun intended)



    Update on this: I’ve installed today’s Blender build, and I still see the same error with the outline effect. I’m attaching screenshots showing how things look without hovering, and how they do while I hover the object I am enabling the outline effect for.


    Hi, this is a rendering bug and we found a way to fix it. See the next Verge3D release coming a bit later.

    Soft8Soft Tech Chief
    X | FB | LinkedIn


    Hi Alexander, these are great news! Thank you very much!

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.