We use cookies to ensure that we give you the best experience on our website. If you continue to use this site we will assume that you are happy with it.

.WebGL GL_INVALID_FRAMEBUFFER_OPERATION: Framebuffer is incomplete

Home Forums WebGL & WebXR Troubleshooting .WebGL GL_INVALID_FRAMEBUFFER_OPERATION: Framebuffer is incomplete

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #52004
    Brian
    Customer

    Hi There,

    I have been troubleshooting this issue for a while now, and no matter what I do, I can’t seem to figure out what is causing these errors:

    [.WebGL-000001F804F21500] GL_INVALID_FRAMEBUFFER_OPERATION: Framebuffer is incomplete: Attachment has zero size.

    [.WebGL-000001F804F21500] GL_INVALID_FRAMEBUFFER_OPERATION: Draw framebuffer is incomplete

    Here is an example page:

    ecoLite

    I Updated to the latest version and updated the html files, but they broke my styles and the interaction quit working.

    I thought it was a sizing issue, so I did a test with a basic cube with no textures and got the same error.

    I am pretty sure I got the custom pre-loader issue working, but I don’t know if it’s the best solution or the “correct” way.

    Side note: Why not add a checkbox when creating a new project to “include a custom pre-loader” and have it create an index.html file automatically?

    Thanks for your help.

    Here are more stats:
    Windows 10
    Google Chrome: Version 101.0.4951.54 (Official Build) (64-bit)
    Website: WordPress Current version: 5.9.3 with Verge3D plugin

    • This topic was modified 5 days, 20 hours ago by Brian.
    Attachments:
    You must be logged in to view attached files.
    #52028

    Hi,

    this error hints that at the moment when WebGL is initialized, the canvas size is 0 pixels.

    This may happen in a dynamic website which starts loading Verge3D app before it properly resized the container element used to include the 3D canvas.

    I checked your link it loads for me fine. But there is indication that Verge3D app is initialized twice. That WebGL error is also present. May be you somehow included another invisible zero pixel Verge3D app in the page?

    Chief 3D Verger | LinkedIn | Twitter

    #52032
    Brian
    Customer

    hmmm… I think it’s very possible. Can you tell me if the way I setup my index.html and (projectname.html) files is correct?

    I tried to consolidate all the shared items on our site:

    ie:
    <script src=”/wp-content/uploads/verge3d/js/v3d.js”></script>

    instead of:
    <script src=”v3d.js”></script>

    I setup a demo page and started with the “Farmer’s Journey” as my base for index.html. (I know that there are calls in the header that are not relevant)

    @3d demo page for testing

    you can see that there are no console warnings or errors, but all my button functionality has broken.

    here is how it’s supposed to work:

    Aeris

    You can see that when you click each element, the annotations no longer popup. See the attached screen shot. I am also including my puzzle xml file if that helps.

    Puzzle XML file

    Thanks so much for your personal response. Your patience is awesome.

    • This reply was modified 5 days ago by Brian. Reason: screenshot missing
    • This reply was modified 5 days ago by Brian.
    Attachments:
    You must be logged in to view attached files.
    #52037
    Brian
    Customer
    • This reply was modified 1 day, 21 hours ago by Brian.
    #52104
    Brian
    Customer

    Ok so I figured out what the problem is and I will attempt to sum up what I found.

    The tutorials provided use Webflow as an example to build a custom preloader. I, instead used Dreamweaver and somehow called the verge3d application 2 times by mistake. Then I added both an index file and an html file and uploaded it to WordPress via the plugin.

    Then when I embedded the presentation via iframe, I ran into issues where the preloader wasn’t being removed after loading.
    The solution was to simply create one index file and add the preloader to it. This solved all loading errors and things seem to be working smoothly.

    #52163

    Excellent! Glad you worked it out! :good:

    Chief 3D Verger | LinkedIn | Twitter

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.