We use cookies to ensure that we give you the best experience on our website. If you continue to use this site we will assume that you are happy with it.

TypeError: Cannot read properties of null (reading ‘slice’)

Home Forums General Questions TypeError: Cannot read properties of null (reading ‘slice’)

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #45766
    Lee
    Customer

    Hi. I am encountering this error message in my console.
    Other apps are working fine, but some apps with multiple parts (especially with large meshes) are showing this message.

    I am not sure what possibly can cause this issue and how I can fix this.
    I found the same topic submited exactly the same with mine in this forum, but he or she finally solved it by removing some parts.

    Any idea I can try it out for this?

    Thank you for your help in advance.

    Attachments:
    You must be logged in to view attached files.
    #45768
    Lee
    Customer

    For your information, I am using blender and the latest version of verge3d.

    #45772
    xeon
    Customer

    Can you expand the TypeError so we can see the rest?
    It seems its having an issue with loading your gltf in general.

    If you haven’t already tried this re-install 3.71 and export the gltf and see if you have the same issue. The 3.8 Blender GLTF exporter may have issues, its a .0 release.

    When you say large models…how large are you talking?
    Do the models comply with the suggested topology for Verge?
    You may want to dump all materials, clean your scene and then export that model again and see if the GLTF causes the TypeError. If it does it might be model-specific…if it doesnt it might be material specific. This doesn’t rule out puzzle errors.

    When you load scenes in your initial scene has to contain all the puzzles of the upcoming scenes to be loaded. You will want to check that the names of the objects in your initial scene that are referencing the new scene are spelled correctly and exist in the new GLTF that is to be loaded. And of course you will want to be sure none of those puzzles can be executed before the scene is fully loaded so be sure those are encapsulated in a procedure and fired after the load.

    You can always share your project and we can take a look.

    Xeon
    Route 66 Digital
    Interactive Solutions

    #45800

    Hi,
    can you please send us one on these apps?

    Verge3D’s Tech Chief
    FB | Twitter | VK

    #46152
    Lee
    Customer

    Hi Xeon,

    Sorry for the late response and thank you so much for your detailed answers.

    I have tried all the solutions you mentioned, but it worked once I created a new app.

    I think it is related gltf bug especially working with some geometries.

    Thank you again for your time.

    #46153
    Lee
    Customer

    Hi Alexander,

    Unfortunately, I deleted the app projects with the troubles.
    But let me share an app with you once I encounter that again for our users.

    Thank you for asking me though.

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.