We use cookies to ensure that we give you the best experience on our website. If you continue to use this site we will assume that you are happy with it.

Swapped axes in 2.15

Home Forums Bug Reports and Feature Requests Swapped axes in 2.15

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #19715
    brownie
    Participant

    Hi,

    I’ve just updated my version to 2.15, updated my app, re-exported the scene from Blender, and then I had the bad surprise to get a broken scene with y and z axis swapped for elements that are rotated via puzzles.

    Did I miss something ?

    #19716

    Hi,

    I believe it was fixed in the latest Verge3D 2.15 build. Please download it again and check whether this issue was fixed (there was a last minute fix with rotation puzzles).

    Verge3D’s Tech Chief
    FB | Twitter | VK

    #19717
    brownie
    Participant

    Hi alexander,

    Well I’ve downloaded it about just 2 hours ago… But I’m gonna try anyway.

    Thanks.

    #19718

    I believe you have the latest version. Please check if you angles are consistent with Blender. If not, can you please provide a link to your project for us to check. Thanks!

    Verge3D’s Tech Chief
    FB | Twitter | VK

    #19719
    brownie
    Participant

    Still have the problem.

    This is what I’ve done :
    -Updated to 2.15 (downloaded a couple of minutes ago)
    -PLaced my app folder in Verge3D
    -Opened Blender and updated my app (except template based files)
    -Opened my app. It worked

    Then :
    -Made a small modification in Blender
    -Exported to WebGL
    -Opened my app. it worked

    Finally :
    -Made a small modification in an existing procedure related to morphs, saved to xml
    -Opened my app : Boom ! swapped axes.

    (note : Objects are not child of others)

    #19727

    Hi,

    Made a small modification in an existing procedure related to morphs, saved to xml

    are you using rotation puzzles there by any chance? how this procedure looks like?

    Chief 3D Verger | LinkedIn | Twitter

    #19731
    brownie
    Participant

    Hi Yuri,

    I’m preparing a packaged version of my app which is highly complex (and in French).

    But I’ve already tried to disable the newly created morphs with no success; PLus I checked that this morph doesn’t affect the elements that are rotated the bad way.

    Thank you

    #19751

    yes, having a simpler project would help us investigate this issue.

    Chief 3D Verger | LinkedIn | Twitter

    #19762
    brownie
    Participant

    Hi Yuri,

    Could you give me an email to send you a Wetransfer link? I can’t post it publicly.

    In the meantime, I’ve made some tests and checkings and still can’t figure out what’s wrong. Maybe the patch you made concerning this problem doesn’t cover every situation.

    regards

    #19763

    sure, please send the link via the contact form – we’ll pick it up!

    Chief 3D Verger | LinkedIn | Twitter

    #19767

    Hi,

    Unfortunately the project you sent us is too big in terms of functionality to debug it efficiently. Could you please try to isolate the issue in a smaller project which only contains functionality relevant to this issue? Thanks!

    Chief 3D Verger | LinkedIn | Twitter

Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.