We use cookies to ensure that we give you the best experience on our website. If you continue to use this site we will assume that you are happy with it.

normal quality in browser

Home Forums Graphics / Blender normal quality in browser

Tagged: ,

Viewing 15 posts - 1 through 15 (of 20 total)
  • Author
    Posts
  • #34070
    thomasup
    Customer

    we are having some issues, that the normal in the browser look quite worse than in the eevee viewport. is there some quality setting for this?
    we are having a high gloss material, which makes these differences look quite bad in the browser.

    #34071

    Can you provide any example?

    Co-founder and lead graphics specialist at Soft8Soft.

    #34073
    thomasup
    Customer

    image01 is in verge3d, image02 in blender.
    same camera, material and all.
    verge3d has this strange “z-shaped” reflection, which is not visible in blender.
    other spots are notably different, too.

    it could be some difference in normal interpolation, the falloff between verts seems more linear / abrupt in verge3d.

    or is there a different precision level used in v3d? high quality normals in blender are disabled.

    the differences are not huge, but since the imperfections are far less visible in blender, it is hard to adjust/fix them. most of them only become visible once exported.

    Edit: attached example blend file

    Edit2: also the normal interpolation seems to be different on the mirrored side.

    • This reply was modified 2 years, 1 month ago by thomasup.
    • This reply was modified 2 years, 1 month ago by thomasup.
    Attachments:
    You must be logged in to view attached files.
    #34078

    It’s because of n-gons, if you’ll triangulate the model in Blender you will get the same quality, but the engine do this automatically before export because n-gons not supported. The only way to this this is to triangulate manually as you need to get the best effect.

    Co-founder and lead graphics specialist at Soft8Soft.

    #34106
    thomasup
    Customer

    true, that sure is a contributing factor.

    we will try to narrow it down further

    #34123

    :good:

    Co-founder and lead graphics specialist at Soft8Soft.

    #56134
    v3dbeginner
    Participant

    I see significantly worse picture in browser (Chrome on MAC) in comparison with the one in viewport (3.1.2): all metals are kind of transparent and glass is not. Comparison below is without glass.
    Tnanks for your help.

    Attachments:
    You must be logged in to view attached files.
    #56167

    Check the blend type of the material and seth test and depth write checkboxes.

    Co-founder and lead graphics specialist at Soft8Soft.

    #56175
    v3dbeginner
    Participant

    Thanks a lot for the quick response!

    I am using default settings and the simplest materials without mixtures and textures, as in your swiss-army-knife example.

    Attachments:
    You must be logged in to view attached files.
    #56193

    can you share the blend file?

    Co-founder and lead graphics specialist at Soft8Soft.

    #56195
    v3dbeginner
    Participant

    sure, how to do it best? Since I am a beginner, it is rather bulky (34 Mb).

    #56199

    you can upload it on some file sharing service and leave the link here.

    Co-founder and lead graphics specialist at Soft8Soft.

    #56302
    v3dbeginner
    Participant

    here we go:
    https://drive.google.com/file/d/15-_q7MBeTsh12K3cmIFSa_Xtzd2Y6wV-/view?usp=sharing

    Please, remove the link after you download the file or let me know so I can remove the file.

    Thank you!

    I am going to order the freelance license as soon as I get the reasonable quality in the browser using the trial version.

    #56335

    You have a scale on the camera, reset it to 1,1,1 and all will be ok.

    Co-founder and lead graphics specialist at Soft8Soft.

    #56338
    v3dbeginner
    Participant

    Thank you, that helped! I guess, the glass remains still not transparent.

Viewing 15 posts - 1 through 15 (of 20 total)
  • You must be logged in to reply to this topic.