We use cookies to ensure that we give you the best experience on our website. If you continue to use this site we will assume that you are happy with it.

Environment light passing through material, lighting back face

Home Forums Bug Reports and Feature Requests Environment light passing through material, lighting back face

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #40652
    randyfiverandyfive
    Customer

    I don’t know why but some objects in some blender files have their normals inverted when I export the Verge3D file or use Sneak Peak. I check the normals are correct in blender but when I export they are inverted. The objects also appear transparent to light if metallic is set >0 in the BSDF shader. I have attached some images and the application folder.

    Blender 2.92.0
    Verge 3D Version: 3.6.1
    Google Chrome and Edge

    Update: I changed the title to better reflect the main problem after solving the first issue where I was inadvertently rendering the back faces.

    • This topic was modified 1 week ago by randyfiverandyfive.
    Attachments:
    You must be logged in to view attached files.
    #40658

    Hi,
    Looks like you render the Back side of your mesh. See the attached screenshot.

    Attachments:
    You must be logged in to view attached files.

    Co-founder and CTO at Soft8Soft
    FB | Twitter | VK

    #40662
    randyfiverandyfive
    Customer

    Thanks, I must have clicked that when I was trying to solve the other problem and didn’t realize what I did.
    Now that that is fixed, however,

      I still see light from the environment passing through the object even though the alpha channel is set to 1.

    See the attached image and application folder again.

    Could you take a look again at this? I can’t figure out why it is doing this.

    Thanks for your help!

    Attachments:
    You must be logged in to view attached files.
    #40685
    randyfiverandyfive
    Customer

    Any ideas on what is wrong with my file?
    Here is an additional video to show that I am rendering the front side but when I do a Sneak Peak, the lights from the environment pass through my model.
    I won’t re-attach the application folder since nothing has changed since my last post above.
    Thank you for taking a look!

    Attachments:
    You must be logged in to view attached files.
    #40697

    This troubles caused by camera scale, if you set camera scale to 1 all will be ok.

    Co-founder and lead graphics specialist at Soft8Soft.

    #40720
    randyfiverandyfive
    Customer

    That fixed the problem! Thank you Mikhail!

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.