We use cookies to ensure that we give you the best experience on our website. If you continue to use this site we will assume that you are happy with it.

Home Forums General Questions Install

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #58901

    I recently tried to update my verge 3d program and can’t seem to get it to work.

    I tried uninstalling the program then re-installing the latest (4.2.0) and it can’t seem to connect for some reason.
    I either get an “internal server error” message or it opens an empty app manager with red text saying that there is a permissions problem.
    I’m not sure why this is happening because I have full access to the folders I am writing to.

    I have tried installing the program in various different folders with no luck. My original install saved some files onto my user folder however whenever I download now by default everything goes into program files?

    I also wondered if there was a way to view apps created using the desktop app template in full screen? Currently when I enter full screen mode there is still a white bar at the top with: file, edit, view etc.

    Any help would be much appreciated.



    Sorry for those troubles. I’d suggest you make a fresh install. Versions 4.x are installed in the system folder which is usually no accessible for writing into. The user folder is selected at first run in the App Manager. So you should only use this user folder, unlike with older Verge3D versions where everything was stored in one place.

    Yes, you can run Electron apps in full screen. To do this, edit the file resources/app/main.js to add the following:

    const win = new BrowserWindow({
        fullscreen: true,
        width: 1280,
        height: 800,
        webPreferences: {
            nodeIntegration: true

    Chief 3D Verger | LinkedIn | Twitter

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.