We use cookies to ensure that we give you the best experience on our website. If you continue to use this site we will assume that you are happy with it.

Exclude Objects from Lights in 3ds Max

Home Forums Graphics / 3ds Max Exclude Objects from Lights in 3ds Max

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #2636
    Avatar3dmdlb
    Customer

    Hello Soft8Soft-Team,
    when i exclude the Button-Planes/Objects from the Lights in my Max-Scene this seems to be not working in my html-File later. In the html-file the Lights affect the Planes again. Is there any way to do that? If this Function cannot be exported from Max, maybe it can be done later in Puzzles?

    Regards Jochen

    #2639

    Hello Soft8Soft-Team,
    when i exclude the Button-Planes/Objects from the Lights in my Max-Scene this seems to be not working in my html-File later. In the html-file the Lights affect the Planes again. Is there any way to do that? If this Function cannot be exported from Max, maybe it can be done later in Puzzles?

    There’s no way to exclude objects from lighting in current version of the engine, but we already added this feature in dev version and will release it during next week.

    Co-founder and lead graphics specialist at Soft8Soft.

    #2642
    Avatar3dmdlb
    Customer

    Hello Mikhail,
    that’s great, thanks for the info!

    #2820
    Avatar3dmdlb
    Customer

    Hi,
    sorry if i’m a little unpatient, but is there already a release date of the new Verge3D-Version for Max? With the “exclude objects from lighting”-function, which is very important for me.

    Regards Jochen

    #2867

    Hi,
    sorry if i’m a little unpatient, but is there already a release date of the new Verge3D-Version for Max? With the “exclude objects from lighting”-function, which is very important for me.

    Regards Jochen

    Hi, the last release of the Verge3D for 3ds max is on the way, but unfortunaly there will be no feature that you want because I think I missunderstud your request. I thought it means excluding from shadowing not from overall lighting. To exclude object from shadow casting you need to remove the Cast|Recieve shadows checkboxes in object’s properties. But excluding an oblect from lights influens is very difficult tusk, I don’t think that it will be possible to support it in near future. Sorry for that.

    Co-founder and lead graphics specialist at Soft8Soft.

    #2876
    Avatar3dmdlb
    Customer

    Hello Mikhail,
    thanks for your reply.
    The problem is, that in my gltf-file, when i rotate or move, the lights will affect the lighting/shadows of buttons i have in the foreground.
    You also have that effect in your recliner-demo-scene. When you rotate or move the shadows/light effects the material-balls.
    Deactivate cast/receive shadows in max has no effect.
    Any idea or workflow to solve this?

    #2887

    Deactivate cast/receive shadows in max has no effect.

    It’s available in last release that is out an hour ago. Try it.

    Any idea or workflow to solve this?

    For now only way to get a shadeless version of the material is to set Self-Illumination of the material to some value higher than 0, but not so heigh. We try to find a working workflow for this, becuse there’s no good solution in 3ds max, may be we add a Shadeless checkbox in next release. Excluding object from the lighting won’t help because the object will be absolutely dark.

    Co-founder and lead graphics specialist at Soft8Soft.

    #2889
    Avatar3dmdlb
    Customer

    Ok sounds good, i will install the new version and try it.
    If excluding objects from lights is working, then it can be a solution. I can exclude the buttons from the main lights and create some extra lights linked to the cam only for the buttons.
    As an idea for later V3D-versions, it might be helpfull to create buttons with puzzles (for people like me without coding-abilities).

    #2900
    Avatar3dmdlb
    Customer

    I tried the new Version, but the Problem cannot be solved with deactivating cast/receive shadows. It’s only working if you adjust the cam in a way that it always stay behind the (spot-)lights.
    Is there any way to create buttons or insert jpg-pics with puzzles/without coding?

    #2909

    I tried the new Version, but the Problem cannot be solved with deactivating cast/receive shadows. It’s only working if you adjust the cam in a way that it always stay behind the (spot-)lights.

    I think I was not clear enough, I said exactly that it won’t help. I also suggested you to use Self-Illumination instead of excluding object from lighing.

    Is there any way to create buttons or insert jpg-pics with puzzles/without coding?

    Yes, we thought about such functionality and already moving to it’s implementation.

    Co-founder and lead graphics specialist at Soft8Soft.

    #2913
    Avatar3dmdlb
    Customer

    Hi Mikhail,
    i understand your suggestion with using self illumination and the deactivating shadows. But when the cam is in the same angel as the light, the light hits the button-plane with “full force” and then there is an overexposure. So also with self-illumination the lights will have an effect.
    But as i said, i found an working solution: Use Spotlights and stay behind behind them with the cam. And activate Self-illumination in the Button-Material, otherwise they stay dark ;-).
    It would be fantastic if there is a “Button-Function” in Puzzles in the Future!

    #2916

    Use Spotlights and stay behind behind them with the cam. And activate Self-illumination in the Button-Material, otherwise they stay dark ;-).
    It would be fantastic if there is a “Button-Function” in Puzzles in the Future!

    Ok, we will think about implementation of both workflow.

    Co-founder and lead graphics specialist at Soft8Soft.

Viewing 12 posts - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.