We use cookies to ensure that we give you the best experience on our website. If you continue to use this site we will assume that you are happy with it.

Disable Rendering (Anti-Alias) puzzle not working on iPad

Home Forums General Questions Disable Rendering (Anti-Alias) puzzle not working on iPad

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #39478
    psedlacek
    Customer

    Hello,

    I have a desktop app that uses this puzzle and it works fine, also works fine on my android phone. When I test on an iPad the rest of the app is great but this particular puzzle isn’t working.

    Is this supported on iOS in Safari?

    Pete

    #39506

    Hi,
    this puzzle should work just fine for iOS devices. Does the Swiss Army Knife demo work on your iPad?

    Verge3D’s Tech Chief
    FB | Twitter | VK

    #39519
    psedlacek
    Customer

    Alex,

    Good idea, I checked and yes the swiss army knife works, and other projects I’ve built work on the iPad.

    For this project that isn’t working, we updated this from an earlier “v.3.3.1” project to 3.6. I can only think it’s for this reason because it works fine on android and PC.

    I can create a brand new puzzle in this project “when clicked do (disable render anti-alias) and it does nothing.

    Pete

    #39598
    jem
    Customer

    Hi Alex,
    I have been working with Pete on this issue. We wanted to understand why antialiasing works in the Swiss Army Knife example and not in our projects.

    We found that this issue is not unique to the iPad. It is a general issue with Safari. You can reproduce the issue on macOS or iOS as long as you are using Safari.

    We found that the difference between the Swiss Army knife project and our projects was HDR rendering. The knife example had HDR enabled. Our projects had HDR disabled.

    Once we enabled HDR in Blender and re-exported the GLTF, antialiasing worked.

    I used the knife models to create two test cases. One with HDR enabled and the other with HDR disabled. Please use Safari to view each of these links:
    Disabled
    Enabled

    I preformed these tests on a fully updated Mac, Verge 3.61, and Blender 2.92. I have attached the two v3d project files to this post.

    Is this expected behavior? If so, is there a cost to enabling HDR on all projects? Thank you.

    Attachments:
    You must be logged in to view attached files.

    Jeremy Wernick

    #39622

    Hi Jem,
    Thanks for sending these two examples. We managed to find out why it’s happening and going to resolve this issue before the upcoming pre-release scheduled later this week.

    Verge3D’s Tech Chief
    FB | Twitter | VK

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.