We use cookies to ensure that we give you the best experience on our website. If you continue to use this site we will assume that you are happy with it.

Cannot load unused materials in puzzles

Home Forums Puzzles Cannot load unused materials in puzzles

Tagged: ,

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #44564

    First of all I want to thank you to the team of Verge3d and specially Yuri for making this platform as user friendly as possible. The tutorials are really helpful and the documentation.
    I have two issues (due to lack of my experience)
    1. I cannot select unused materials in puzzles even when using text puzzles. Used the selector and text puzzle. If I use only one material on the shoes, only that one shows up in the puzzles. Kindly help me.
    2. How do I link html buttons in puzzles. I am using bootstrap to make an interactive html page. I am sure I am missing a step somewhere.
    Thank you again for providing this magnificent platform.
    Here is the project:

    https://cdn.soft8soft.com/AROAJSY2GOEHMOFUVPIOE:bb3eb2c877/applications/Nike AF1/Nike AF1.html

    <iframe width=”1024″ height=”640″ allowfullscreen src=”https://cdn.soft8soft.com/AROAJSY2GOEHMOFUVPIOE:bb3eb2c877/applications/Nike AF1/Nike AF1.html”></iframe>


    Hi there ABBAS….
    The links seem to be broken … at least when I tried them so I will answer part 1.

    Unable to select “unused materials”. To change materials or textures all materials/textures you want to use or switch between need to be loaded into the scene. One option is to take the materials that are not selectable or visible in puzzles is to created 3d planes Blender, Max or whatever you are using. Map the material you want to use to the plane (you don’t care about UVs) for this. Then scale the object so that is small and hidden in another object in your scene or hide it off camera. Export the GLTF and then you will be able to select the new material via puzzles….The trick is the materail you want to use has to be in the scene.

    Route 66 Digital
    Interactive Solutions - https://www.r66d.com
    Tutorials - https://www.xeons3dlab.com


    Thank you for the reply. I did that and it works now.
    I figured out the html part. It was a small mistake.
    Thank you again

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.