We use cookies to ensure that we give you the best experience on our website. If you continue to use this site we will assume that you are happy with it.

Blender 4.02/4.1 on Mac Internal Server Error 500 for Verge3D 4.5.1 and 4.6

Home Forums Bug Reports and Feature Requests Blender 4.02/4.1 on Mac Internal Server Error 500 for Verge3D 4.5.1 and 4.6

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #72011
    Toby Wilson


    After installing Blender 4.1 earlier this week I installed Verge3D 4.6 on my Mac running MacOS 14.4.1 and now the application manager will not start. I get the following error: 500: Internal Server Error whether I use Chrome or Safari. Verge3D was working before the upgrades.

    I tried downgrading to Blender 4.02 and Verge3D 4.5.1 and it gave me the same error. I tried clearing Chrome’s cache, no go.

    Here is what I get from Blender’s console when I try to run the application manager:

    Read blend: “/Volumes/Files/Blender/Web_Apps/swiss_army_knife_toby/swiss_army_knife_toby_v2.blend”
    Starting App Manager server (port 8668, package BLENDER)
    Address already in use, exiting
    Uncaught exception GET / (::1)
    HTTPServerRequest(protocol=’http’, host=’localhost:8668′, method=’GET’, uri=’/’, version=’HTTP/1.1′, remote_ip=’::1′)
    Traceback (most recent call last):
    File “/Volumes/Files/Blender/verge3d_blender_451/manager/lib/tornado/web.py”, line 1713, in _execute
    result = await result
    File “/Volumes/Files/Blender/verge3d_blender_451/python/pluginUtils/../../manager/server.py”, line 1827, in get
    await server.runAsync(self.rootRequestThread)
    File “/Volumes/Files/Blender/verge3d_blender_451/python/pluginUtils/../../manager/server.py”, line 383, in runAsync
    return await asyncio.wrap_future(executor.submit(func, *args, **kwargs))
    File “/Applications/Blender.app/Contents/Resources/4.1/python/lib/python3.11/concurrent/futures/thread.py”, line 58, in run
    result = self.fn(*self.args, **self.kwargs)
    File “/Volumes/Files/Blender/verge3d_blender_451/python/pluginUtils/../../manager/server.py”, line 1848, in rootRequestThread
    File “/Volumes/Files/Blender/verge3d_blender_451/python/pluginUtils/../../manager/server.py”, line 1009, in genAppViewInfo
    if self.isPuzzlesBasedFile(join(app[‘appsDir’], html)):
    File “/Volumes/Files/Blender/verge3d_blender_451/python/pluginUtils/../../manager/server.py”, line 531, in isPuzzlesBasedFile
    with open(path, ‘r’, encoding=’latin_1′) as f:
    IsADirectoryError: [Errno 21] Is a directory: ‘/Volumes/Files/Blender/Web_Apps/horse_building_block_test_01/index.html’
    500 GET / (::1) 254.76ms

    Any help to get Verge3D working again will be appreciated!



    Hi Toby,

    Very strange: it’s saying that it is not an HTML file but a directory – /Volumes/Files/Blender/Web_Apps/horse_building_block_test_01/index.html.

    Could you please check? If it’s a directory, you might need to get rid of it (be sure to backup your project beforehand).

    Soft8Soft Tech Chief
    X | FB | LinkedIn

    Toby Wilson

    Hi Alexander,

    I found the culpret after some expermentation this morning. Turns out my horse_building_block_test_project was the offending project. Within the project folder was a subfolder titled “index.html” and within that was a index.html.html and a gwd_workspace.json file. Apparently these were created by Google’s Web Designer App when I was trying it out. Removal of the directory appears to have solved the issue for now and I can load the application manager. I’ve attached a zipped copy of this directory for your reference if needed.

    Thanks for your help.

    You must be logged in to view attached files.

    Hi Toby,
    Thanks for sharing the files. Even if it’s kinda awkward that index.html is used as a directory we’re still going to upgrade the App Manager so that it can handle such cases. The fix will land in the next Verge3D update!

    Soft8Soft Tech Chief
    X | FB | LinkedIn

    Toby Wilson

    Thanks for doing a work around for that situtation, it seems like a bad idea to name a forder index.html to me. As luck would have it, in the end I didn’t like Google Web Designer anyway. Maybe I’ll look back at in the future.

    Thanks for your help, have a great week!

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.