We use cookies to ensure that we give you the best experience on our website. If you continue to use this site we will assume that you are happy with it.

Auto-rotate slowed

Home Forums Bug Reports and Feature Requests Auto-rotate slowed

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #18177
    rhenriques
    Customer

    The autorotate puzzle works well but, when the mouse is moved over the model while rotating, the movement gets slow and choppy.
    Cheers

    #18178

    Hi,

    Does the slowdown happen if you use just a single autorotate puzzle and the default cube scene?

    Chief 3D Verger | LinkedIn | Twitter

    #18199
    rhenriques
    Customer

    Hi Yuri

    I have not tested with the default cube scene. The slowdown happens with a several thousand faces polygon model. If the mouse is not moved, things are smooth. Once the mouse is moved around, without doing nothing (click for instance), the movement gets choppy.
    My puzzle layout is the one in the image attached.
    Cheers

    Attachments:
    You must be logged in to view attached files.
    #18201

    Are you using any mouse movement event puzzles? Can you provide a link on Verge3D Network for us to test your app?

    Chief 3D Verger | LinkedIn | Twitter

    #18221
    rhenriques
    Customer

    Hi Yuri

    From your message I’ve detected that the puzzle in the attached image is the culprit. It seems that these events (object auto rotate and mouse events) do interfere. Is there anyway to make them coexist in peace?
    Draft upload is here

    https://cdn.soft8soft.com/AROAJSY2GOEHMOFUVPIOE:bf62d91879/applications/PedraFurada/PedraFurada.html

    Click on the green ball lower left, then on the yellow dots then on the white ball lower left. Drag the mouse around while the model moves and you will see the lag.

    Cheers

    • This reply was modified 3 years, 1 month ago by rhenriques.
    Attachments:
    You must be logged in to view attached files.
    #18237

    I see you also detect camera movement and enable/disable rendering. The problem is that the mouse picking operation is computationally very expensive for high-poly models, and this operation may be not able to complete in time with render frames.

    I suggest to disable camera movement detection if the camera is in auto-rotate mode.

    Chief 3D Verger | LinkedIn | Twitter

    #18256
    rhenriques
    Customer

    Hi Yuri

    Thank you so much. I’ll try to check that out. By disabling mouse detection for cursor change on hover things get normal. I guess that, for now, I’ll be using this methodology. I was sorting things out to now add an html skin to this model and replicate to other models.
    Best Regards

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.