We use cookies to ensure that we give you the best experience on our website. If you continue to use this site we will assume that you are happy with it.

Verge App not working on IPhone/IPad

Home Forums General Questions Verge App not working on IPhone/IPad

Tagged: , ,

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #58891
    Armin Bastl
    Customer

    Hi!

    We have a wonderful Verge Application, which works perfect on PC/Laptop/MacBook/Smartphones. Only on Apple smart devices (Iphone/Ipad) it does not work. We tested on several Iphone 14 and 12, also Ipad Airs and Ipad Pros (2016-2021 Models) – Safari, Chrome, Brave Browser.
    What is the Problem? When opening the Application it gets stuck in a “loading loop”. So the loading Window comes up, loads, when finished the whole page refreshes and the loading starts again. Sometimes the application loads after a few “Loading loops”, but no consitency in that. Other times it loads and then we only get a white screen. On one Ipad it did load properly once, but the transparency in one material did not work.
    We use Verge with Blender. We have tried it with Blender Version 3.3.1 and 3.3.0 and Verge Versions 4.2, 4.1.1, 4.0.1. The creation and usage of a new “naked” Blender file did not solve the problem. Our bin has 2.6mb/compressed bin 1.7mb – gltf 52kb. The file has around 37k triangles. In our Materials we use Alpha. In our puzzles there is only basic logic (play animation, sound and a camera rotation toggle). But we also had the problem when we didnt use any puzzles. We only use a small HDRI/jpg as light source.

    We cannot reproduce all the above stated with any non apple device. It loads perfectly fast on all other devices, even on ancient androit phones. We also dont have that problem with any other of our verge applications that were created in the last 4 weeks.

    I sadly cannot provide the files because of NDA’s.

    I hope someone can help or has a solution.

    Best regards!

    #58892
    Armin Bastl
    Customer

    I forgot to mention that on one Ipad Pro 11 In – 2nd generation it does work properly

    #58893

    Hi,

    It can be that the textures are very big or non-power-of-two, and the app crashes because of memory overflow.

    you can try to enable texture compression to see if this is the reason https://www.soft8soft.com/docs/manual/en/introduction/Texture-Compression.html#enabling_texture_compression

    Chief 3D Verger | LinkedIn | Twitter

    #58894
    kdv
    Participant

    show the app

    #58895

    another option is to use the puzzle check performance to adjust to poor hardware https://www.soft8soft.com/docs/manual/en/puzzles/System.html#check_performance

    Chief 3D Verger | LinkedIn | Twitter

    #58896
    Armin Bastl
    Customer

    Hi Yuri,

    thanks for the reply.
    The textures are relatively small. B< far smaller than e.g. the “Scooter” App, which loads perfecly fine.
    Very few are non power of two, we’ll change that and I’ll update.

    Poor Hardware would be strange, since Iphone 14 and IPads with the M2 Chip have ar greater hardware than a Samsung from 2014… but we’ll check that too.

    Thanks for th input. I hope this helps.

    #58897
    Mariusz
    Customer

    Be careful with using “check performance”. When I use it in combination with “when clicked” and “all objects” puzzles (to check performance when I click anything anywhen), then it causes problems on iPhones as you described.

    #58900

    you can also try disabling shadows or post-process effects specifically on iOS.

    Chief 3D Verger | LinkedIn | Twitter

    #58902
    Armin Bastl
    Customer

    Hi!

    Its always the little things… Thanks for the heads up with the non power of two textures.

    Workes fine now!

    Best regards

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.