We use cookies to ensure that we give you the best experience on our website. If you continue to use this site we will assume that you are happy with it.

Lookat constraint – Keep offset being ignored

Home Forums Graphics / 3ds Max Lookat constraint – Keep offset being ignored

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #36481
    Avatarweb
    Customer

    Hello,
    I’ve got a Lookat constraint with “Keep inital offset” enabled in 3dsMax. But as soon as I export the scene to verge3d, the object behaves if the “Keep initial offest” is turned off.

    Any chance I can control this?

    • This topic was modified 2 months, 3 weeks ago by Avatarweb.
    #36517

    Hi,

    unfortunately, this setting is not supported at the moment. :unsure:

    3D Verger, the CEO
    LinkedIn | FB | Twitter | VK | 新浪微博

    #36529
    Avatarpsedlacek
    Customer

    You could try straightening out your object and resetting transforms, then apply the lookat constraint. This may or may not be simple depending on your rig. I had to do this with a hydraulic piston recently and it allowed me to disable the “keep initial offset” setting.

    #36560
    Avatarweb
    Customer

    Is it possible to implement that option in future versions?

    Is there any other option, maybe with the constrain puzzles from verge? I’m trying to recreate the slight rotation effect when you move the cursor. So that the geometry is always facing to the mouse cursor with a slight delay.


    @psedlacek

    Yeah, I already thought about constraining the object and then rotating the pivot so that its facing the correct way, just a bit tedious.

    #36566

    I’ll discuss this with the team! :good:

    3D Verger, the CEO
    LinkedIn | FB | Twitter | VK | 新浪微博

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.