We use cookies to ensure that we give you the best experience on our website. If you continue to use this site we will assume that you are happy with it.

Can see through an object’s backfaces

Home Forums General Questions Can see through an object’s backfaces

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #56361
    sazzrro
    Participant

    Hello, I’m using Blender to build my 3D environment and have noticed after setting my material’s verge3d render setting to “Double Sided” that I can now see the backfaces but can also see other parts of the mesh through the backfaces for some reason. Is there another setting that I would need to change in order to have the backfaces be more solid?

    Also, in AR mode, I see parts of the scene on the faces of the mesh

    • This topic was modified 2 months ago by sazzrro.
    Attachments:
    You must be logged in to view attached files.
    #56366
    xeon
    Customer

    What version of blender and V3D are you using?
    I have been experimenting with a cube and a single plane and the only time I can get even close to the types of issues you are having is when I use a metallic material with an alpha blend. Since you are using double sided materials, metalics can look odd when they are very glossy and have the alpha blend on. If that’s not the issue for you… create a simplified scene with a basic cube and a plane using the same materials you are using in your scene and see if you can recreate the problem. If you can…post that blend file where we can load it and try it out.

    Xeon
    Route 66 Digital
    Interactive Solutions - https://www.r66d.com

    #56369
    sazzrro
    Participant

    I’m on Blender version 3.0.1

    Thanks for the feedback, I tried changing the metallic value of my materials but saw the same issue occur. I also tried using a basic default material and only changing its base color to a blue color, but the same issue still occur with that as well.

    I’ll attach my blend file here:

    Edit:
    For some reason, it does not let me send the blend file after I hit submit. It’ll say that I edited the post but no file is actually attached. I’ve also tried sending it as a .zip file. The .blend file size is 25.8kb and the file size for the .zip file is 4.3kb

    • This reply was modified 2 months ago by sazzrro.
    • This reply was modified 2 months ago by sazzrro.
    • This reply was modified 2 months ago by sazzrro.
    • This reply was modified 2 months ago by sazzrro.
    • This reply was modified 2 months ago by sazzrro.
    #56375
    sazzrro
    Participant

    Here’s a screenshot of my material settings since it won’t let me upload the blend file:

    The two left-most nodes are Texture Coordinate(Pink node) and Voronoi Texture (Orange node)

    • This reply was modified 2 months ago by sazzrro.
    • This reply was modified 2 months ago by sazzrro.
    Attachments:
    You must be logged in to view attached files.
    #56380
    kdv77kdv
    Participant

    It’s an issue of the gtaoGenerator. Disable AO and the “x-ray vision” will disappear

    #56384
    sazzrro
    Participant

    Thank you! Disabling Ambient Occlusion fixed both the 3D and the AR issue with the materials

    #56385
    kdv77kdv
    Participant

    Changing the blend mode from Opaque to Alpha Clip also removes this issue

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.