We use cookies to ensure that we give you the best experience on our website. If you continue to use this site we will assume that you are happy with it.

3D configurator model to AR

Home Forums Puzzles 3D configurator model to AR

Viewing 15 posts - 16 through 30 (of 30 total)
  • Author
    Posts
  • #53193
    pimmartens
    Participant

    Hi,

    I’m trying to scale my model through shape keys as you can see in the attached image. That works great when looking at it in 3d. But when I open it in AR, the model is back to it’s original size.

    How do I keep my morph factor when exporting to USDZ?

    Thanks!

    • This reply was modified 2 weeks, 3 days ago by pimmartens.
    Attachments:
    You must be logged in to view attached files.
    #53256
    vern
    Customer

    So is ‘1’ the scale you want when going into USDZ or are you changing that number again somewhere else?

    #53257
    pimmartens
    Participant

    The ‘1’ is just to see if I was able to get the scaled model in AR. Later I want to have more morph shapes.

    #53261
    vern
    Customer

    Try putting all of the puzzles below the 2 morph puzzles in a ‘after seconds’ puzzle from the Time tab. I’d say try 2 or 3 seconds just to test and make sure it doesn’t have to do with the morph targets not being finished when the USDZ is exported. Let me know if it’s still the same issue.

    #53414
    pimmartens
    Participant

    Hi Vern, it still opens in the same size. I’ve added a screenshot of the puzzle in case I’ve misunderstood your explanation.

    Attachments:
    You must be logged in to view attached files.
    #53580
    vern
    Customer

    Ok yeah you did set the ‘after seconds’ puzzle correctly.

    If you’re ok with sending your project or a sample of it that replicates the issue I would be more than willing to check it to figure out why it isn’t updating.

    • This reply was modified 1 week, 2 days ago by vern.
    #53596
    pimmartens
    Participant

    Thanks for the help Vern! I’ve attached the project.

    • This reply was modified 1 week, 2 days ago by pimmartens.
    #53599
    pimmartens
    Participant

    Test to see if the attachment is working… Does the attachment need to be approved or something before it shows it in the post?

    • This reply was modified 1 week, 2 days ago by pimmartens.
    #53603
    kdv77kdv
    Participant

    Does the attachment need to be approved or something before it shows it in the post?

    Nope. They just don’t allow to attach archives ))) Use cloud services…

    #53604
    pimmartens
    Participant
    #53625
    vern
    Customer

    I get an error when trying to open or when trying to unzip your AR Test 2 folder that you sent.

    Can you send it again as a .zip instead of a .rar folder?

    Also be sure to check that you can download it from here once you add it because if you can’t than that means no one else can either.

    #53652
    pimmartens
    Participant

    It seems to work fine for me. I’ve added a new version in a .zip.

    https://we.tl/t-jv8kxpJCic

    #53691
    vern
    Customer

    I’m going to test it fully tomorrow but I think I see the problem already.
    It looks like you have the AR button set up twice, especially if you copied from the Augmented_Reality demo.

    In the meantime try this:

    1. Save all of the puzzles you have in your test to the library.

    2. Start a new project using the base template (Standard Light template for example)

    3. Add the saved puzzles to that new project and export your model from Blender to Verge3D.

    4. See if it works as intended now.

    Let me know your results.

    #53694
    pimmartens
    Participant

    I’ve tried following your steps. I ended up with a scene where I can rotate my model, but no way to get into AR.
    After copying the code from the .html file of the ar demo and the placing the enter_AR_button.png in the media folder I was able to open it in AR, but nothing seems to have changed.

    • This reply was modified 5 days, 19 hours ago by pimmartens.
    #53770
    vern
    Customer

    I’m still looking into this problem. It seems that USDZ files do not support morph targets. I’m looking to see if there’s still a way to send the morphed model to USDZ.

Viewing 15 posts - 16 through 30 (of 30 total)
  • You must be logged in to reply to this topic.