We use cookies to ensure that we give you the best experience on our website. If you continue to use this site we will assume that you are happy with it.

Strange Problems with Transparent Background

Home Forums Bug Reports and Feature Requests Strange Problems with Transparent Background

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #4504
    donalffons
    Customer

    Hi,

    Here is a potential bug report.

    I have two blend files, that contain pretty much the same items: A camera, a cube and a light. I then use the following code to make my background white:
    app.scene.background = new THREE.Color(1,1,1);
    The files give different results:
    test123 works as expected, background is white (1,1,1)
    test123-bug creates a slightly grey background color (…and has some other problems with transparency, but I think that’s related)

    I greatly appreciate your support.

    Cheers
    -Sebastian

    • This topic was modified 3 years, 4 months ago by donalffons.
    • This topic was modified 3 years, 4 months ago by donalffons.
    Attachments:
    You must be logged in to view attached files.
    #4554

    Hi Sebastian,

    The difference is because of the SSAO postprocessing effect, which is enabled in test123-bug, but isn’t in test123. SSAO darkens the whole image a bit, that’s why the background is slightly grey.

    But you’re right that it’s not what’s expected, because SSAO shouldn’t affect an empty background so much. We’ll make a fix for it by the next release. Until then, you can just disable this effect, it’s the Shading -> Ambient Occlusion option in the Properties Panel.

    Co-founder and lead developer at Soft8Soft.

    #4555
    donalffons
    Customer

    Hi Ivan, thanks a lot for your explanation!

    I don’t find that option you mentioned. Here is how the render settings look like for me (still using Verge3d 2.3.1)
    render settings

    Maybe I just have to update to the new version?!

    #4556

    No, you don’t need to update, it’s in the other panel, they are just named the same for some reason:
    ao.png

    Attachments:
    You must be logged in to view attached files.

    Co-founder and lead developer at Soft8Soft.

    #4559

    it’s the Shading -> Ambient Occlusion option in the Properties Panel

    yeah, my bad, I meant the Properties Shelf of course, not the Properties Panel

    Co-founder and lead developer at Soft8Soft.

    #4560
    donalffons
    Customer

    Thank you, Sir! That does the trick.

    #4561

    Glad to hear! :good:

    Co-founder and lead developer at Soft8Soft.

    #4562
    donalffons
    Customer

    One more problem: If I have ambient occlusion turned on, then I cannot enable a transparent background any more with:

    app.scene.background = null;
    app.renderer.setClearColor(0x000000, 0);

    The background will be black. It works if AO is disabled.

    Do you know any workaround for this?

    #4590

    The background will be black. It works if AO is disabled.

    Yes, it’s a bug, we’ll fix it in the next release, thanks for reporting!
    Regarding a workaround: unfortunately I don’t see a simple one, because the opaque background was hard-coded directly in the SSAO shader.

    Co-founder and lead developer at Soft8Soft.

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.