Stoping a partly playing animation

Home Forums Puzzles Stoping a partly playing animation

This topic contains 5 replies, has 2 voices, and was last updated by  Bildermensch 5 days, 9 hours ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #5662

    Bildermensch
    Participant

    Hi there,
    since i am past my problems with not showing animations, i a was able to get much further in my project and made significant progress. The problem i have now is as follows: I have a button object and a camera with an animation (80frames). When the button gets klicked, i want to play a part of that animation (40 frames) and stop it there.
    How do i do that? In my current puzzle setup it just goes on and on. It sticks to the defined frame range but does not stop. How can I archive that?
    Regards,
    Heiner

    • This topic was modified 5 days, 11 hours ago by  Bildermensch.
    Attachments:
    You must be logged in to view attached files.
    #5665

    Bildermensch
    Participant

    Hi,
    just to mention i also tried “Pause Animation” and “Set Animation to Frame” without scucess …
    Regards
    Heiner

    #5666

    How do i do that? In my current puzzle setup it just goes on and on. It sticks to the defined frame range but does not stop. How can I archive that?

    What type of loop mode set on the object with animation? Try to set it at once, this must help.

    Co-founder and lead graphics specialist at Soft8Soft.

    #5669

    Bildermensch
    Participant

    Hi Mikhail,
    as you can see in the screen i seperated the two animations now. First i let the animation of the button play after the click, and the i want to let the animation of the camera play (FRame 1-40). Problem is, in the node which lets me select limited frames to play, there is no way to select a play modus (once, repeat etc). When i put a play anim node in front and set tit to once, it plays the full anim once. So i started to make a construct of play anim with frame nr. and put a stop animation after it, but that is also not working.
    Regards,
    Heiner

    Attachments:
    You must be logged in to view attached files.
    #5671

    as you can see in the screen i seperated the two animations now. First i let the animation of the button play after the click, and the i want to let the animation of the camera play (FRame 1-40). Problem is, in the node which lets me select limited frames to play, there is no way to select a play modus (once, repeat etc). When i put a play anim node in front and set tit to once, it plays the full anim once.

    Yes, i know that. But play animation from-to always took type of looping from Blender’s object preferences so to avoid repeating you need to set it once in blender before export.

    Co-founder and lead graphics specialist at Soft8Soft.

    #5672

    Bildermensch
    Participant

    Aaaaaah, in Blender. Try that right away!

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.