We use cookies to ensure that we give you the best experience on our website. If you continue to use this site we will assume that you are happy with it.

Something wrong with “draw line from object” puzzle.

Home Forums Puzzles Something wrong with “draw line from object” puzzle.

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #38878
    Avatarrhenriques
    Customer

    Hi

    I had a few projects with annotations that worked great before Verge 3D 3.4. After this version and until the last one 3.6.1, the puzzle “draw line from object” seem to be linking correctly only to one of the objects being the lines draw to some point outside the object. Is this a bug or something must be changed in the puzzles sequence? See attached the right and wrong app and a puzzle example.

    Best Regards

    • This topic was modified 1 month, 2 weeks ago by Avatarrhenriques.
    Attachments:
    You must be logged in to view attached files.
    #38894

    hi,

    please make sure you have updated your app for the new version (it should print 3.6.1 in the console), AND re-saved your Puzzles.

    3D Verger, the CEO
    LinkedIn | FB | Twitter | VK | 新浪微博

    #38898
    Avatarrhenriques
    Customer

    hi,

    please make sure you have updated your app for the new version (it should print 3.6.1 in the console), AND re-saved your Puzzles.

    Hi Yuri. Thank you so much for the answer. No luck. I’m on version 3.6.1 and things continue to be wrong. My pristine version, updated until Verge 3.2 (I guess), it is working perfectly. I can be doing something wrong while re-saving the puzzles or refreshing the app. What’s the best practice?
    Cheers

    #38928
    Avatarrhenriques
    Customer

    No matter what I try, line does not connect as expected.
    The verge3d app is in an iframe included in a parent html page.

    • This reply was modified 1 month, 2 weeks ago by Avatarrhenriques.
    #39142
    Avatarrhenriques
    Customer

    Updated to the experimental 3.7 pre 1 and still has the same problem.

    #39576
    Avatarrhenriques
    Customer

    In 3.7 pre 2, things get a little bit more ruined. Annotations do not appear at all and the lines are not drawn. It’s the Mac app that used to work just fine. Help please!

    #39580

    Hi, unfortunately we can’t reproduce the issue on our own demos and test scenes. Can you please share your project files?

    Co-founder and CTO at Soft8Soft
    FB | Twitter | VK

    #39597
    Avatarrhenriques
    Customer

    Hi Alexander

    Thank you so much!
    The working project is this one (do not update).

    https://u.pcloud.link/publink/show?code=XZ6yiBXZFKGyCe9p8jXcfwpQjFYK0fw5L5Oy

    The one that does not work as expected after updates is this one

    https://u.pcloud.link/publink/show?code=XZxyiBXZgxIweNhBzCmHGJHlSz4vCbd01Az7

    Best Regards

    #39626

    Hi,
    These projects helped a lot! We’re going to fix this bug ASAP. Check out the upcoming Verge3D preview build (scheduled in a few days).

    P.S: Also please note, we have changed “add HTML element” some time ago. It no longer adds “position: absolute” option to the created elements (which is required to position your hidden elements properly with “bind element”). The most straighforward way to assign this property is to add the following puzzle somewhere in your code (does not matter where).

    Attachments:
    You must be logged in to view attached files.

    Co-founder and CTO at Soft8Soft
    FB | Twitter | VK

    #39652
    Avatarrhenriques
    Customer

    Thank you so much Alexander!
    I’ll be waiting for the fix. I’ll also try to fix the method for generate the binding, as you suggested.
    Best regards

    PS: Got the fix today with the latest 3.7 preview 3. Outstanding work! Work as expected now. Thank you so much Alexander!

    • This reply was modified 3 weeks, 1 day ago by Avatarrhenriques.
    #39794

    Hi,
    I have tested it in the 3.7 preview 3 and it doesn’t work, the lines continue to go to the right of the screen.
    What could be wrong ?

    #39795

    Hi,

    Make sure you updated your up for 3.7 pre3 (version is printed in browser console) and resaved the Puzzles.

    3D Verger, the CEO
    LinkedIn | FB | Twitter | VK | 新浪微博

    #39796

    I’m sure for both, 3.7 pre3 and puzzle resaved.
    I have tested with my own puzzle an the one shared by rhenriques (resaved and added position:absolute css rule) and both don’t work.

    (could be very cool if the annotation puzzle could have a draw line from object build in function…)

    #39829
    Avatarrhenriques
    Customer

    Like Laurent, I do not always have success by drawing correctly the line. The project shared with Alexander worked from the previous version but others “not always” work. I agree a lot with Laurent’s suggestion for having a puzzle for making an annotation that could have a draw line from a object build in function. This way we could create a few dummy neutral objects, placed in a certain annotation wanted origin, to draw a line from them quickly.
    Best regards

Viewing 14 posts - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.