We use cookies to ensure that we give you the best experience on our website. If you continue to use this site we will assume that you are happy with it.

sneak peak is not detecting my object and material

Home Forums Graphics / Blender sneak peak is not detecting my object and material

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #25065
    Avatarlokesh
    Newbie

    I’m a complete newbie, that being said, I try the sneak peak in the blender file, I’ve attached below and it doesn’t work at all. can you please tell me where im going wrong and any help would be appreciated.

    Attachments:
    You must be logged in to view attached files.
    #25067

    Hi,

    There’s a shader crash in the browser console for one of the scene materials. That’s why some objects are not rendered at all. Apparently, it’s a bug in the engine. Thanks for the example, we’re going to investigate this issue.

    Co-founder and lead developer at Soft8Soft.

    #25068
    Avatarlokesh
    Newbie

    is there any workaround I can do to avoid this from happening? I read somewhere that baking might help but I’m confused on how to proceed further as my entire project was based upon verge3d working and now I am totally clueless

    #25076

    is there any workaround I can do to avoid this from happening? I read somewhere that baking might help

    This issue is related to the clearcoat effect. So, I think the easiest workaround that can be applied is to just disable it. In your scene it’s used in “Material.001” in the Principled BSDF node. If you set the clearcoat input to 0 the issue will be gone.

    Co-founder and lead developer at Soft8Soft.

    #25080
    Avatarlokesh
    Newbie

    thanks, it totally worked :yahoo: :yahoo: :yahoo: . the model in sneak peek doesn’t look as realistic as the one rendered in the blender and also why isn’t the studio lighting not being shown in the browser. :cry: :cry: :cry:

    I have made the changes regarding the clearcoat and attached the blender file below

    again I’m new to this so please bear patience.

    thanks in advance!

    • This reply was modified 2 months, 1 week ago by Avatarlokesh. Reason: ive added my model render by blender and verge3d for your comparison
    Attachments:
    You must be logged in to view attached files.
    #25086

    thanks, it totally worked . the model in sneak peek doesn’t look as realistic as the one rendered in the blender and also why isn’t the studio lighting not being shown in the browser.

    We don’t suport Area lights yet, that’s why you can see only some ambient lighting in the browser.
    Also, the engine aims to be consistent with Blender’s Eevee viewport but not so much with Cycles, because Cycles is less suitable for realtime rendering :unsure:
    I’d suggest to change the Render Engine option to Eevee, that way you’ll get more similar results between Blender and verge3d.

    Co-founder and lead developer at Soft8Soft.

    #25088
    Avatarlokesh
    Newbie

    thank you so much! atlast everything worked out the way i wanted :yahoo: :yahoo: :yahoo:

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.