We use cookies to ensure that we give you the best experience on our website. If you continue to use this site we will assume that you are happy with it.

No bloom & Sharp edges on mobile devices

Home Forums General Questions No bloom & Sharp edges on mobile devices

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #43006

    Hi verge3d community,

    On desktop i’ve no issue, but while displaying my scene on mobile device i have a lot of aliasing and bloom effect is turn off.

    When i force my mobile browser to run in desktop mode, i don’t have issue with aliasing unless if i switch to fullscreen mode..bloom effect still doesn’t work.

    I’m using one 8196×8196 texture, anisotropic filtering set to x16 in blender.
    In puzzle i only have bloom effect and setscreenscale to native mode, seems like this one don’t change anything.

    Thanks by advance. =)

    You must be logged in to view attached files.

    Hi there,
    What version of Verge3d are you running?
    Can you post your puzzle code for your bloom?
    Did you fork your code making unique specific changes for mobile and desktop or are they the same?

    I just tested some of my files for bloom on mobile and its all working as expected so hopefully after reviewing what/how you are implementing it we can figure it out.

    Route 66 Digital
    Interactive Solutions


    Verge3D 3.7, i did some changes in my puzzle code, following the same than swiss army knife, and it work! =)
    I have bloom now, and less aliasing on mobile with enable/disable rendering puzzle, aliasing is due to emit fresnel too thin on the edges i think.


    Some mobile devices may not support HDRI rendering so bloom ellefct will may not work if threshold too height, otherwise if you set it low it will bloom even gray (lower 1.0 brightness) colors.

    Co-founder and lead graphics specialist at Soft8Soft.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.