We use cookies to ensure that we give you the best experience on our website. If you continue to use this site we will assume that you are happy with it.

Mirrored Objects not being display correctly

Home Forums Graphics / 3ds Max Mirrored Objects not being display correctly

  • This topic has 8 replies, 2 voices, and was last updated 2 months ago by web.
Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #43144
    web
    Customer

    Hey guys,

    I’m having a hard time with 3d objects which are mirrored in 3ds max. When I scatter objects which are getting randomly flipped, verge is displaying them in a black shade which is semi transparant. Is there anything to change that behaviour in verge3d?

    #43234

    Can you uload the example file with issue?

    Co-founder and lead graphics specialist at Soft8Soft.

    #43248
    web
    Customer

    Sure, but you can reproduce it pretty quickly. Take any geometry, create an instance and then mirror that instance with the default settings.

    Attached you find the max file and gltf

    Attachments:
    You must be logged in to view attached files.
    #43251

    The pot has – Y scale set it to positive, the engine wont properly recalculate – scales.

    Attachments:
    You must be logged in to view attached files.

    Co-founder and lead graphics specialist at Soft8Soft.

    #43253
    web
    Customer

    Hmm, I see. But this is the normal way 3ds Max handle mirrors. So there is no way to workaround this on verge3d side?

    #43266

    Try to reset xform for this object before export.

    Attachments:
    You must be logged in to view attached files.

    Co-founder and lead graphics specialist at Soft8Soft.

    #43268
    web
    Customer

    I know about xForm but this destroys the instance. I would like to keep the instancing.

    #43269

    Unrotunally, we can’t fix that on our side.

    Co-founder and lead graphics specialist at Soft8Soft.

    #43277
    web
    Customer

    Okay, then this is just something I’ve to keep in mind.

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.