We use cookies to ensure that we give you the best experience on our website. If you continue to use this site we will assume that you are happy with it.

[SOLVED] Install addon : ModuleNotFoundError: No module named ‘imp’

Home Forums Graphics / Blender [SOLVED] Install addon : ModuleNotFoundError: No module named ‘imp’

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #74884
    Fabulous FOUR

    Hi, I have installed Blender / Verge3D on a newly configured Manjaro Linux PC. Blender is working fine but when I install Verge3D, when activating the addon, I have this output :

    Traceback (most recent call last):
      File "/usr/share/blender/4.1/scripts/modules/addon_utils.py", line 376, in enable
        mod = importlib.import_module(module_name)
      File "/usr/lib/python3.12/importlib/__init__.py", line 90, in import_module
        return _bootstrap._gcd_import(name[level:], package, level)
      File "<frozen importlib._bootstrap>", line 1387, in _gcd_import
      File "<frozen importlib._bootstrap>", line 1360, in _find_and_load
      File "<frozen importlib._bootstrap>", line 1331, in _find_and_load_unlocked
      File "<frozen importlib._bootstrap>", line 935, in _load_unlocked
      File "<frozen importlib._bootstrap_external>", line 995, in exec_module
      File "<frozen importlib._bootstrap>", line 488, in _call_with_frames_removed
      File "/home/joseph/app/Blender/verge3d_blender/addons/verge3d/__init__.py", line 32, in <module>
        import imp
    ModuleNotFoundError: No module named 'imp'

    Blender : 4.1.1
    Verge3D : 4.6.0
    Python : 3.12.3

    Operating System : Manjaro Linux
    KDE Plasma Version: 6.0.5
    KDE Frameworks Version: 6.2.0
    Qt Version: 6.7.1
    Kernel Version: 6.9.3-3-MANJARO (64-bit)
    Graphics Platform: X11
    Processors: 20 × Intel® Core™ i9-10900K CPU @ 3.70GHz
    Memory: 94.1 Gio of RAM
    Graphics Processor: NVIDIA GeForce RTX 3070/PCIe/SSE2
    Manufacturer: Micro-Star International Co., Ltd.
    Product Name: MS-7C75
    System Version: 2.0

    Fast search gives me a possible deprecation of imp module. is it the problem ?
    Deprecated since version 3.4: The imp package is pending deprecation in favor of importlib.


    This issue was fixed in Verge3D 4.7 pre1. Please check it out to confirm it works for you.

    Soft8Soft Tech Chief
    X | FB | LinkedIn

    Fabulous FOUR

    Ok, it’s fine, that’s the solution. Thank you very much !

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.