We use cookies to ensure that we give you the best experience on our website. If you continue to use this site we will assume that you are happy with it.

Flipped normals and wrong materials Assignments in Verge3D

Home Forums Graphics / 3ds Max Flipped normals and wrong materials Assignments in Verge3D

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #35233
    vklein
    Customer

    Hello,

    I’m getting quite many flipped normals and wrong material assignments on my objects in Verge3D. Especially multi material ID seams wrongly exchanged and even complete wrong (arbitriary material from the scene) materials laid on objects. Very clean extruded geometry, no shady normals in the geometry in 3dsmax. Is there a global cause known causing this?
    3dsmax 2012 with Verge 3.4.0.

    • This topic was modified 1 year, 9 months ago by vklein.
    #35244

    Can you share the 3ds max files with the issues?

    Co-founder and lead graphics specialist at Soft8Soft.

    #35265
    vklein
    Customer

    Sure,

    first a screenshot from Verge after Sneak peak in browser(Chrome):
    https://download.mediaprojekt.eu/index.php/s/M24BTHfBgCY3JS2

    screenshot M=wrong (multi)material, N = flipped normals

    here the 3dsmax 2021 scene with enough assets to see the problems:
    https://download.mediaprojekt.eu/index.php/s/BeKBjPgXJ7nAGbR

    the scene is not finally optimized, I’ve encountered the mentioned problems and halted work on this. On the upper profile I’ve collapsed the aluminium and plastic profile together from their extruded spline state, trying to solve the problems, the flipped normals and wrong (multi)materials occured on other places thereafter.

    • This reply was modified 1 year, 9 months ago by vklein.
    • This reply was modified 1 year, 9 months ago by vklein.
    • This reply was modified 1 year, 9 months ago by vklein.
    • This reply was modified 1 year, 9 months ago by vklein.
    #35282

    Very difficult to understand the problem in big project, can you isolate few object with the problems?

    Co-founder and lead graphics specialist at Soft8Soft.

    #35287
    vklein
    Customer

    Ok,
    now only a few objects and a camera

    https://download.mediaprojekt.eu/index.php/s/EJH9T9EGoCCiM2B

    First problem:
    wrong (multi)material allocation on the outer shells (look at the red material in 3dsmax and where it lands in Verge)

    Second problem:
    Look at the crisp reflection on the sides (wrong material landing on them), what the heck is the grey sphere in the reflections?

    I’ve fixed the normals problem, 3dsmax made some strange things with extrusions.

    #35296

    Soryy, can’t find any red material on the scene at all. Can you name it?

    Attachments:
    You must be logged in to view attached files.

    Co-founder and lead graphics specialist at Soft8Soft.

    #35315
    vklein
    Customer

    The black one on the outer profile. Multimaterial Called “N_ALU”, 3rd submaterial “Aussen”.
    Color it red or anything else.
    ->sneak peak
    materials on the profiles are exchanged randomly

    #35316

    I’v tested your model and seems like all materials placed fine, I’ve just removed metallic from the materials and you can see that them all placed right.

    Attachments:
    You must be logged in to view attached files.

    Co-founder and lead graphics specialist at Soft8Soft.

    #35358
    vklein
    Customer

    And I am getting this:
    see attachment

    Attachments:
    You must be logged in to view attached files.
    #35360
    vklein
    Customer

    Even reducing the file down to only 2 objects and 2 materials with totally different materials than my metals exports a file with metals on. Thinking of some old cache error. Tried 3 browsers (Chrome, Firefox, Vivaldi), with scene never loaded before, same result.
    Verge somehow caches materials from history on export?
    Other scenes, mine and Verge demos export fine.

    • This reply was modified 1 year, 8 months ago by vklein.
    #35362

    May be you have simmilar name for objects/groups others?

    Co-founder and lead graphics specialist at Soft8Soft.

    #35363
    vklein
    Customer

    Rescaling scene to meters, resetting trsnsformations/scale, renaming aery object to unique names and attaching non working objects to working objects fixed the problems for now. This particular 3ds max scene was cursed, I don’t want to bother you anymore with this shit.

    #35379

    Glad it fixed, I think that thing may happen because of naming.

    Co-founder and lead graphics specialist at Soft8Soft.

Viewing 13 posts - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.